CHUQ.CSCT.IRIS.Service Namespace

Documentation du service IRIS
CHUQ.CSCT.IRIS.Service Namespace

[Ceci est une documentation préliminaire, sous réserve de modification.]

Espace de nom racine du service IRIS.
Classes
 | Class | Description
Public class | ServiceIris | Service IRIS.
Interfaces
 | Interface | Description
Public interface | IServiceIris | Interface du service IRIS.

IRIS 2017


IServiceIris Interface

IServiceIris Interface

Interface du service IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public interface IServiceIris
Public Interface IServiceIris

The IServiceIris type exposes the following members.

Methods
 | Name | Description
Public method | Ajouter | Méthode permettant d'ajouter une réservation au système IRIS.
Public method | Modifier | Méthode permettant de modifier une réservation au système IRIS.
Public method | ObtenirActivites | Méthode permettant d'obtenir la liste des activités disponibles pour un type d'activité.
Public method | ObtenirInstallations | Méthode permettant d'obtenir la liste des installations (établissement) pour une réservation IRIS.
Public method | ObtenirReservation | Méthode permettant d'obtenir une réservation IRIS.
Public method | ObtenirReservationPourSysteme | Méthode permattant de retourner toutes les réservations IRIS pour une liste de systèmes pour une période donnée.
Public method | ObtenirReservationsPourUtilisateur | Méthode permettant d'obtenir la liste de réservations d'un utilisateur pour une période donnée.
Public method | ObtenirSpecialites | Méthode permettant d'obtenir la liste des spécialités disponbiles pour une réservation IRIS.
Public method | ObtenirSysteme | Méthode permettant d'obtenir un système IRIS par son identifiant.
Public method | ObtenirSystemes | Méthode permettant d'obtienir la liste des systèmes IRIS disponibles pour l'utilisateur qui appel le service IRIS.
Public method | ObtenirTypes | Méthode permettant d'obtenir la liste des types disponbiles pour une réservation IRIS.
Public method | ObtenirUtilisateurs | Méthode permettant d'obtenir la liste des utilisateurs IRIS.
Public method | Supprimer | Méthode permettant de supprimer une réservation ou une occurence de réservation d'une série.
Public method | SupprimerSerie | Méthode permettant de supprimer une série de réservation IRIS.
Top
Remarks
Ce service permet notamment a des applications tierces de faire des réservations dans IRIS.
See Also

Reference

CHUQ.CSCT.IRIS.Service Namespace


IServiceIris Methods

IServiceIris Methods

The IServiceIris type exposes the following members.

Methods
 | Name | Description
Public method | Ajouter | Méthode permettant d'ajouter une réservation au système IRIS.
Public method | Modifier | Méthode permettant de modifier une réservation au système IRIS.
Public method | ObtenirActivites | Méthode permettant d'obtenir la liste des activités disponibles pour un type d'activité.
Public method | ObtenirInstallations | Méthode permettant d'obtenir la liste des installations (établissement) pour une réservation IRIS.
Public method | ObtenirReservation | Méthode permettant d'obtenir une réservation IRIS.
Public method | ObtenirReservationPourSysteme | Méthode permattant de retourner toutes les réservations IRIS pour une liste de systèmes pour une période donnée.
Public method | ObtenirReservationsPourUtilisateur | Méthode permettant d'obtenir la liste de réservations d'un utilisateur pour une période donnée.
Public method | ObtenirSpecialites | Méthode permettant d'obtenir la liste des spécialités disponbiles pour une réservation IRIS.
Public method | ObtenirSysteme | Méthode permettant d'obtenir un système IRIS par son identifiant.
Public method | ObtenirSystemes | Méthode permettant d'obtienir la liste des systèmes IRIS disponibles pour l'utilisateur qui appel le service IRIS.
Public method | ObtenirTypes | Méthode permettant d'obtenir la liste des types disponbiles pour une réservation IRIS.
Public method | ObtenirUtilisateurs | Méthode permettant d'obtenir la liste des utilisateurs IRIS.
Public method | Supprimer | Méthode permettant de supprimer une réservation ou une occurence de réservation d'une série.
Public method | SupprimerSerie | Méthode permettant de supprimer une série de réservation IRIS.
Top
See Also

Reference

IServiceIris Interface
CHUQ.CSCT.IRIS.Service Namespace


IServiceIris.Ajouter Method

IServiceIrisAjouter Method

Méthode permettant d'ajouter une réservation au système IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Reservation Ajouter(
    Reservation reservation,
    Identite identite,
    FuseauHoraire fuseauHoraire
)
Function Ajouter (
    reservation As Reservation,
    identite As Identite,
    fuseauHoraire As FuseauHoraire
) As Reservation

Parameters

reservation
Type: CHUQ.CSCT.IRIS.Service.Modele.ReservationReservation
Réservation IRIS.
identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.
fuseauHoraire
Type: CHUQ.CSCT.IRIS.Service.EnumerationsFuseauHoraire
Fuseau horaire Canadien.

Return Value

Type: Reservation
La réservation ayant été ajoutée à IRIS (L'identifiant de réservation renseignée).
See Also

Reference

IServiceIris Interface
CHUQ.CSCT.IRIS.Service Namespace


IServiceIris.Modifier Method

IServiceIrisModifier Method

Méthode permettant de modifier une réservation au système IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
void Modifier(
    Reservation reservation,
    Identite identite,
    FuseauHoraire fuseauHoraire
)
Sub Modifier (
    reservation As Reservation,
    identite As Identite,
    fuseauHoraire As FuseauHoraire
)

Parameters

reservation
Type: CHUQ.CSCT.IRIS.Service.Modele.ReservationReservation
Réservation IRIS.
identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.
fuseauHoraire
Type: CHUQ.CSCT.IRIS.Service.EnumerationsFuseauHoraire
Fuseau horaire Canadien.
See Also

Reference

IServiceIris Interface
CHUQ.CSCT.IRIS.Service Namespace


IServiceIris.ObtenirActivites Method

IServiceIrisObtenirActivites Method

Méthode permettant d'obtenir la liste des activités disponibles pour un type d'activité.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Activite[] ObtenirActivites(
    int identifiantTypeActivite,
    Identite identite
)
Function ObtenirActivites (
    identifiantTypeActivite As Integer,
    identite As Identite
) As Activite()

Parameters

identifiantTypeActivite
Type: SystemInt32
Identifiant du type d'activité.
identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Activite
Liste des activités correspondantes au type d'activité.
See Also

Reference

IServiceIris Interface
CHUQ.CSCT.IRIS.Service Namespace


IServiceIris.ObtenirInstallations Method

IServiceIrisObtenirInstallations Method

Méthode permettant d'obtenir la liste des installations (établissement) pour une réservation IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Installation[] ObtenirInstallations(
    Identite identite
)
Function ObtenirInstallations (
    identite As Identite
) As Installation()

Parameters

identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Installation
Liste des installations (établissement).
See Also

Reference

IServiceIris Interface
CHUQ.CSCT.IRIS.Service Namespace


IServiceIris.ObtenirReservation Method

IServiceIrisObtenirReservation Method

Méthode permettant d'obtenir une réservation IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Reservation ObtenirReservation(
    int identifiantReservationPublic,
    Identite identite
)
Function ObtenirReservation (
    identifiantReservationPublic As Integer,
    identite As Identite
) As Reservation

Parameters

identifiantReservationPublic
Type: SystemInt32
Identifiant de réservation IRIS.
identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Reservation
La réservation IRIS correspondant à l'identifiant de réservation IRIS fournis en entré.
See Also

Reference

IServiceIris Interface
CHUQ.CSCT.IRIS.Service Namespace


IServiceIris.ObtenirReservationPourSysteme Method

IServiceIrisObtenirReservationPourSysteme Method

Méthode permattant de retourner toutes les réservations IRIS pour une liste de systèmes pour une période donnée.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Reservation ObtenirReservationPourSysteme(
    string[] identifiantsSysteme,
    DateTime dateDebut,
    DateTime dateFin,
    Identite identite
)
Function ObtenirReservationPourSysteme (
    identifiantsSysteme As String(),
    dateDebut As DateTime,
    dateFin As DateTime,
    identite As Identite
) As Reservation

Parameters

identifiantsSysteme
Type: SystemString
Identifiant de réservation IRIS.
dateDebut
Type: SystemDateTime
Date et heure de début UTC.
dateFin
Type: SystemDateTime
Date et heure de fin UTC.
identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Reservation
Un tableau de réservation IRIS.
See Also

Reference

IServiceIris Interface
CHUQ.CSCT.IRIS.Service Namespace


IServiceIris.ObtenirReservationsPourUtilisateur Method

IServiceIrisObtenirReservationsPourUtilisateur Method

Méthode permettant d'obtenir la liste de réservations d'un utilisateur pour une période donnée.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Reservation[] ObtenirReservationsPourUtilisateur(
    UtilisateurBase utilisateur,
    DateTime dateDebut,
    DateTime dateFin,
    Identite identite
)
Function ObtenirReservationsPourUtilisateur (
    utilisateur As UtilisateurBase,
    dateDebut As DateTime,
    dateFin As DateTime,
    identite As Identite
) As Reservation()

Parameters

utilisateur
Type: CHUQ.CSCT.IRIS.Service.Modele.UtilisateurUtilisateurBase
Utilisateur propriétaire de la réservation.
dateDebut
Type: SystemDateTime
Date et heure de début UTC pour la recherche.
dateFin
Type: SystemDateTime
Date et heure de fin UTC pour la recherche.
identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Reservation
Liste des réservations IRIS de l'utilisateur pour la page de date fournis.
See Also

Reference

IServiceIris Interface
CHUQ.CSCT.IRIS.Service Namespace


IServiceIris.ObtenirSpecialites Method

IServiceIrisObtenirSpecialites Method

Méthode permettant d'obtenir la liste des spécialités disponbiles pour une réservation IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Specialite[] ObtenirSpecialites(
    Identite identite
)
Function ObtenirSpecialites (
    identite As Identite
) As Specialite()

Parameters

identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Specialite
Liste des spécialités.
See Also

Reference

IServiceIris Interface
CHUQ.CSCT.IRIS.Service Namespace


IServiceIris.ObtenirSysteme Method

IServiceIrisObtenirSysteme Method

Méthode permettant d'obtenir un système IRIS par son identifiant.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Systeme ObtenirSysteme(
    string identifiantSysteme,
    Identite identite
)
Function ObtenirSysteme (
    identifiantSysteme As String,
    identite As Identite
) As Systeme

Parameters

identifiantSysteme
Type: SystemString
Numéro de série du système.
identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Systeme
Le système correspondant.
See Also

Reference

IServiceIris Interface
CHUQ.CSCT.IRIS.Service Namespace


IServiceIris.ObtenirSystemes Method

IServiceIrisObtenirSystemes Method

Méthode permettant d'obtienir la liste des systèmes IRIS disponibles pour l'utilisateur qui appel le service IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Systeme[] ObtenirSystemes(
    Identite identite
)
Function ObtenirSystemes (
    identite As Identite
) As Systeme()

Parameters

identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Systeme
Liste des systèmes.
See Also

Reference

IServiceIris Interface
CHUQ.CSCT.IRIS.Service Namespace


IServiceIris.ObtenirTypes Method

IServiceIrisObtenirTypes Method

Méthode permettant d'obtenir la liste des types disponbiles pour une réservation IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Type[] ObtenirTypes(
    Identite identite
)
Function ObtenirTypes (
    identite As Identite
) As Type()

Parameters

identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Type
Liste des types.
See Also

Reference

IServiceIris Interface
CHUQ.CSCT.IRIS.Service Namespace


IServiceIris.ObtenirUtilisateurs Method

IServiceIrisObtenirUtilisateurs Method

Méthode permettant d'obtenir la liste des utilisateurs IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Utilisateur[] ObtenirUtilisateurs(
    Identite identite
)
Function ObtenirUtilisateurs (
    identite As Identite
) As Utilisateur()

Parameters

identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Utilisateur
Liste des utilisateurs.
See Also

Reference

IServiceIris Interface
CHUQ.CSCT.IRIS.Service Namespace


IServiceIris.Supprimer Method

IServiceIrisSupprimer Method

Méthode permettant de supprimer une réservation ou une occurence de réservation d'une série.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
void Supprimer(
    int identifiantPublic,
    Nullable<DateTime> dateHeureModificationInitiale,
    Identite identite,
    FuseauHoraire fuseauHoraire
)
Sub Supprimer (
    identifiantPublic As Integer,
    dateHeureModificationInitiale As Nullable(Of DateTime),
    identite As Identite,
    fuseauHoraire As FuseauHoraire
)

Parameters

identifiantPublic
Type: SystemInt32
Identifiant de la Réservation IRIS.
dateHeureModificationInitiale
Type: SystemNullableDateTime
Date et heure de la modification initiale.
identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.
fuseauHoraire
Type: CHUQ.CSCT.IRIS.Service.EnumerationsFuseauHoraire
Fuseau horaire Canadien.
See Also

Reference

IServiceIris Interface
CHUQ.CSCT.IRIS.Service Namespace


IServiceIris.SupprimerSerie Method

IServiceIrisSupprimerSerie Method

Méthode permettant de supprimer une série de réservation IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
void SupprimerSerie(
    int identifiantPublic,
    Nullable<DateTime> dateHeureModificationInitiale,
    Identite identite,
    FuseauHoraire fuseauHoraire
)
Sub SupprimerSerie (
    identifiantPublic As Integer,
    dateHeureModificationInitiale As Nullable(Of DateTime),
    identite As Identite,
    fuseauHoraire As FuseauHoraire
)

Parameters

identifiantPublic
Type: SystemInt32
Identifiant de la Réservation IRIS.
dateHeureModificationInitiale
Type: SystemNullableDateTime
Date et heure de la modification initiale.
identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.
fuseauHoraire
Type: CHUQ.CSCT.IRIS.Service.EnumerationsFuseauHoraire
Fuseau horaire Canadien.
See Also

Reference

IServiceIris Interface
CHUQ.CSCT.IRIS.Service Namespace


ServiceIris Class

ServiceIris Class

Service IRIS.
Inheritance Hierarchy
SystemObject
CHUQ.CSCT.IRIS.ServiceServiceIris

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public class ServiceIris : IServiceIris
Public Class ServiceIris
    Implements IServiceIris

The ServiceIris type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceIris | Constructeur du service IRIS.
Top
Methods
 | Name | Description
 | Ajouter | Ajoute une réservation au système IRIS.
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
 | Modifier | Modifie une réservation existante au système IRIS.
 | ObtenirActivites | Méthode permettant d'obtenir la liste des activités disponibles pour une réservation IRIS.
 | ObtenirInstallations | Méthode permettant d'obtenir la liste des installations (établissement) pour une réservation IRIS.
 | ObtenirReservation | Méthode permettant d'obtenir une réservation IRIS.
 | ObtenirReservationPourSysteme | Méthode permettant de retourner toutes les réservations IRIS pour une liste de systèmes pour une période donnée.
 | ObtenirReservationsPourUtilisateur | Méthode permettant de retourner les réservations IRIS ayant été créé par un utilisateur spécifique pour une période de temps spécifié.
 | ObtenirSpecialites | Méthode permettant d'obtenir la liste des spécialités disponbiles pour une réservation IRIS.
 | ObtenirSysteme | Méthode permettant d'obtient un système IRIS par son identifiant.
 | ObtenirSystemes | Méthode permettant d'obtenir la liste des systèmes IRIS disponibles pour l'utilisateur qui appel le service IRIS.
 | ObtenirTypes | Méthode permettant d'obtenir la liste des types disponbiles pour une réservation IRIS.
 | ObtenirUtilisateurs | Méthode permettant d'obtenir la liste des utilisateurs IRIS.
 | Supprimer | Méthode permettant de supprimer une réservation ou une occurence de réservation d'une série.
 | SupprimerSerie | Méthode permettant de supprimer une série de réservation IRIS.
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
See Also

Reference

CHUQ.CSCT.IRIS.Service Namespace


ServiceIris Constructor

ServiceIris Constructor

Constructeur du service IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public ServiceIris()
Public Sub New
See Also

Reference

ServiceIris Class
CHUQ.CSCT.IRIS.Service Namespace


ServiceIris Methods

ServiceIris Methods

The ServiceIris type exposes the following members.

Methods
 | Name | Description
 | Ajouter | Ajoute une réservation au système IRIS.
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
 | Modifier | Modifie une réservation existante au système IRIS.
 | ObtenirActivites | Méthode permettant d'obtenir la liste des activités disponibles pour une réservation IRIS.
 | ObtenirInstallations | Méthode permettant d'obtenir la liste des installations (établissement) pour une réservation IRIS.
 | ObtenirReservation | Méthode permettant d'obtenir une réservation IRIS.
 | ObtenirReservationPourSysteme | Méthode permettant de retourner toutes les réservations IRIS pour une liste de systèmes pour une période donnée.
 | ObtenirReservationsPourUtilisateur | Méthode permettant de retourner les réservations IRIS ayant été créé par un utilisateur spécifique pour une période de temps spécifié.
 | ObtenirSpecialites | Méthode permettant d'obtenir la liste des spécialités disponbiles pour une réservation IRIS.
 | ObtenirSysteme | Méthode permettant d'obtient un système IRIS par son identifiant.
 | ObtenirSystemes | Méthode permettant d'obtenir la liste des systèmes IRIS disponibles pour l'utilisateur qui appel le service IRIS.
 | ObtenirTypes | Méthode permettant d'obtenir la liste des types disponbiles pour une réservation IRIS.
 | ObtenirUtilisateurs | Méthode permettant d'obtenir la liste des utilisateurs IRIS.
 | Supprimer | Méthode permettant de supprimer une réservation ou une occurence de réservation d'une série.
 | SupprimerSerie | Méthode permettant de supprimer une série de réservation IRIS.
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
See Also

Reference

ServiceIris Class
CHUQ.CSCT.IRIS.Service Namespace


ServiceIris.Ajouter Method

ServiceIrisAjouter Method

Ajoute une réservation au système IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Reservation Ajouter(
    Reservation reservation,
    Identite identite,
    FuseauHoraire fuseauHoraire
)
Public Function Ajouter (
    reservation As Reservation,
    identite As Identite,
    fuseauHoraire As FuseauHoraire
) As Reservation

Parameters

reservation
Type: CHUQ.CSCT.IRIS.Service.Modele.ReservationReservation
La réservation
identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.
fuseauHoraire
Type: CHUQ.CSCT.IRIS.Service.EnumerationsFuseauHoraire
Le fuseau horaire dans lequel la réservation doit être réalisé.

Return Value

Type: Reservation
La réservation ayant été créé.

Implements

IServiceIrisAjouter(Reservation, Identite, FuseauHoraire)
Examples
Exemple typique d'utilisation:
C#
VB
Copy
//Exemple à venir.
Imports CHUQ.CSCT.IRIS.Service
Imports System.Globalization

Public Class Exemple

    'Valeurs connues.
    Private Const TypeTeleconsultation = 1
    Private Const IdentifiantActivite = 1
    Private Const IdentifiantSpecialite = 1
    Private Const IdentifiantInstallation = 1

    Public Shared Sub Main()
        Try
            'Ajout de la réservation.
            Using service As New ServiceIrisClient()
                service.Ajouter(ConstruireReservationIrisBidon())
            End Using
        Catch(erreurValidation As IrisException)
            Console.WriteLine(String.Format(CultureInfo.InvariantCulture, "Message de validation. Code : {0}. Message : {1}", erreurValidation.Code, erreurValidation.Message)
        Catch(erreurTechnique As SystemeIrisException)
            Console.WriteLine(String.Format(CultureInfo.InvariantCulture, "Une erreur technique imprévue s'est produite. Code : {0}. Message : {1}", erreurTechnique.Code, erreurTechnique.Message)
        End Try
    End Sub

    Private Shared Function ConstruireReservationIrisBidon() As Reservation
        Return New Reservation With {.Titre = "Titre",
                                     .DateDebut = #12/31/2017 1:15:00 AM#
                                     .DateFin = #12/31/2017 2:15:00 AM#
                                     .Description = "Description de la réservation"
                                     .Commentaire = "Commentaire"
                                     .Type = TypeTeleconsultation
                                     .SousTypeReservation = SousTypeReservation.SansPatient
                                     .IdentifiantActivite = IdentifiantActivite
                                     .IdentifiantSpecialite = IdentifiantSpecialite
                                     .NombrePatient = 1
                                     .NombreIntervenant = 1
                                     .Accessibilite = Accessibilite.Publique
                                     .Accreditation = True
                                     .ActivitePayante = True
                                     .DescriptionActivitePayante = "Description de l'activité payante"
                                     .DescriptionAccreditation = "Description de l'accréditation"
                                     .Conferencier = "Nom du conférencier"
                                     .IdentifiantInstallationOrganisateur = IdentifiantInstallation
                                     .NomInstallationOrganisateurAutre = Nothing
                                     .TypeConnexion = TypeConnexion.ReservationSeulement
                                     .ModeAffichage = ModeAffichage.AmeliorationPresenceContinue
                                     .PreTest = PreTest.Aucune}
    End Function
End Class
See Also

Reference

ServiceIris Class
CHUQ.CSCT.IRIS.Service Namespace


ServiceIris.Modifier Method

ServiceIrisModifier Method

Modifie une réservation existante au système IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public void Modifier(
    Reservation reservation,
    Identite identite,
    FuseauHoraire fuseauHoraire
)
Public Sub Modifier (
    reservation As Reservation,
    identite As Identite,
    fuseauHoraire As FuseauHoraire
)

Parameters

reservation
Type: CHUQ.CSCT.IRIS.Service.Modele.ReservationReservation
La réservation IRIS.
identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.
fuseauHoraire
Type: CHUQ.CSCT.IRIS.Service.EnumerationsFuseauHoraire
Fuseau horaire Canadien.

Implements

IServiceIrisModifier(Reservation, Identite, FuseauHoraire)
Examples
Exemple typique d'utilisation:
C#
VB
Copy
//Exemple à venir.
'Exemple à venir.
See Also

Reference

ServiceIris Class
CHUQ.CSCT.IRIS.Service Namespace


ServiceIris.ObtenirActivites Method

ServiceIrisObtenirActivites Method

Méthode permettant d'obtenir la liste des activités disponibles pour une réservation IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Activite[] ObtenirActivites(
    int identifiantTypeActivite,
    Identite identite
)
Public Function ObtenirActivites (
    identifiantTypeActivite As Integer,
    identite As Identite
) As Activite()

Parameters

identifiantTypeActivite
Type: SystemInt32
Identifiant du type d'activité.
identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Activite
Liste des activités correspondantes au type d'activité.

Implements

IServiceIrisObtenirActivites(Int32, Identite)
Examples
Exemple typique d'utilisation:
C#
VB
Copy
//Exemple à venir.
'Exemple à venir.
See Also

Reference

ServiceIris Class
CHUQ.CSCT.IRIS.Service Namespace


ServiceIris.ObtenirInstallations Method

ServiceIrisObtenirInstallations Method

Méthode permettant d'obtenir la liste des installations (établissement) pour une réservation IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Installation[] ObtenirInstallations(
    Identite identite
)
Public Function ObtenirInstallations (
    identite As Identite
) As Installation()

Parameters

identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Installation
Liste des installations (établissement).

Implements

IServiceIrisObtenirInstallations(Identite)
Examples
Exemple typique d'utilisation:
C#
VB
Copy
//Exemple à venir.
'Exemple à venir.
See Also

Reference

ServiceIris Class
CHUQ.CSCT.IRIS.Service Namespace


ServiceIris.ObtenirReservation Method

ServiceIrisObtenirReservation Method

Méthode permettant d'obtenir une réservation IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Reservation ObtenirReservation(
    int identifiantReservationPublic,
    Identite identite
)
Public Function ObtenirReservation (
    identifiantReservationPublic As Integer,
    identite As Identite
) As Reservation

Parameters

identifiantReservationPublic
Type: SystemInt32
Identifiant de réservation IRIS.
identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Reservation
La réservation IRIS correspondant à l'identifiant de réservation IRIS fournis en entré.

Implements

IServiceIrisObtenirReservation(Int32, Identite)
Examples
Exemple typique d'utilisation:
C#
VB
Copy
//Exemple à venir.
'Exemple à venir.
See Also

Reference

ServiceIris Class
CHUQ.CSCT.IRIS.Service Namespace


ServiceIris.ObtenirReservationPourSysteme Method

ServiceIrisObtenirReservationPourSysteme Method

Méthode permettant de retourner toutes les réservations IRIS pour une liste de systèmes pour une période donnée.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Reservation ObtenirReservationPourSysteme(
    string[] identifiantsSysteme,
    DateTime dateDebut,
    DateTime dateFin,
    Identite identite
)
Public Function ObtenirReservationPourSysteme (
    identifiantsSysteme As String(),
    dateDebut As DateTime,
    dateFin As DateTime,
    identite As Identite
) As Reservation

Parameters

identifiantsSysteme
Type: SystemString
Identifiant de réservation IRIS.
dateDebut
Type: SystemDateTime
Date et heure de début UTC.
dateFin
Type: SystemDateTime
Date et heure de fin UTC.
identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Reservation
Un tableau de réservation IRIS.

Implements

IServiceIrisObtenirReservationPourSysteme(String, DateTime, DateTime, Identite)
Examples
Exemple typique d'utilisation:
C#
VB
Copy
//Exemple à venir.
'Exemple à venir.
See Also

Reference

ServiceIris Class
CHUQ.CSCT.IRIS.Service Namespace


ServiceIris.ObtenirReservationsPourUtilisateur Method

ServiceIrisObtenirReservationsPourUtilisateur Method

Méthode permettant de retourner les réservations IRIS ayant été créé par un utilisateur spécifique pour une période de temps spécifié.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Reservation[] ObtenirReservationsPourUtilisateur(
    UtilisateurBase utilisateur,
    DateTime dateDebut,
    DateTime dateFin,
    Identite identite
)
Public Function ObtenirReservationsPourUtilisateur (
    utilisateur As UtilisateurBase,
    dateDebut As DateTime,
    dateFin As DateTime,
    identite As Identite
) As Reservation()

Parameters

utilisateur
Type: CHUQ.CSCT.IRIS.Service.Modele.UtilisateurUtilisateurBase
Utilisateur propriétaire de la réservation.
dateDebut
Type: SystemDateTime
Date et heure de début UTC.
dateFin
Type: SystemDateTime
Date et heure de fin UTC.
identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Reservation
Liste des réservations IRIS ayant été créé par l'utilisateur spécifié en entré pour la plage de date fournis.

Implements

IServiceIrisObtenirReservationsPourUtilisateur(UtilisateurBase, DateTime, DateTime, Identite)
Examples
Exemple typique d'utilisation:
C#
VB
Copy
//Exemple à venir.
'Exemple à venir.
See Also

Reference

ServiceIris Class
CHUQ.CSCT.IRIS.Service Namespace


ServiceIris.ObtenirSpecialites Method

ServiceIrisObtenirSpecialites Method

Méthode permettant d'obtenir la liste des spécialités disponbiles pour une réservation IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Specialite[] ObtenirSpecialites(
    Identite identite
)
Public Function ObtenirSpecialites (
    identite As Identite
) As Specialite()

Parameters

identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Specialite
Liste des spécialités.

Implements

IServiceIrisObtenirSpecialites(Identite)
Examples
Exemple typique d'utilisation:
C#
VB
Copy
//Exemple à venir.
'Exemple à venir.
See Also

Reference

ServiceIris Class
CHUQ.CSCT.IRIS.Service Namespace


ServiceIris.ObtenirSysteme Method

ServiceIrisObtenirSysteme Method

Méthode permettant d'obtient un système IRIS par son identifiant.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Systeme ObtenirSysteme(
    string identifiantSysteme,
    Identite identite
)
Public Function ObtenirSysteme (
    identifiantSysteme As String,
    identite As Identite
) As Systeme

Parameters

identifiantSysteme
Type: SystemString
Numéro de série du système.
identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Systeme
Le système correspondant.

Implements

IServiceIrisObtenirSysteme(String, Identite)
Examples
Exemple typique d'utilisation:
C#
VB
Copy
//Exemple à venir.
'Exemple à venir.
See Also

Reference

ServiceIris Class
CHUQ.CSCT.IRIS.Service Namespace


ServiceIris.ObtenirSystemes Method

ServiceIrisObtenirSystemes Method

Méthode permettant d'obtenir la liste des systèmes IRIS disponibles pour l'utilisateur qui appel le service IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Systeme[] ObtenirSystemes(
    Identite identite
)
Public Function ObtenirSystemes (
    identite As Identite
) As Systeme()

Parameters

identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Systeme
Liste des systèmes.

Implements

IServiceIrisObtenirSystemes(Identite)
Examples
Exemple typique d'utilisation:
C#
VB
Copy
//Exemple à venir.
'Exemple à venir.
See Also

Reference

ServiceIris Class
CHUQ.CSCT.IRIS.Service Namespace


ServiceIris.ObtenirTypes Method

ServiceIrisObtenirTypes Method

Méthode permettant d'obtenir la liste des types disponbiles pour une réservation IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Type[] ObtenirTypes(
    Identite identite
)
Public Function ObtenirTypes (
    identite As Identite
) As Type()

Parameters

identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Type
Liste des types.

Implements

IServiceIrisObtenirTypes(Identite)
Examples
Exemple typique d'utilisation:
C#
VB
Copy
//Exemple à venir.
'Exemple à venir.
See Also

Reference

ServiceIris Class
CHUQ.CSCT.IRIS.Service Namespace


ServiceIris.ObtenirUtilisateurs Method

ServiceIrisObtenirUtilisateurs Method

Méthode permettant d'obtenir la liste des utilisateurs IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Utilisateur[] ObtenirUtilisateurs(
    Identite identite
)
Public Function ObtenirUtilisateurs (
    identite As Identite
) As Utilisateur()

Parameters

identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.

Return Value

Type: Utilisateur
Liste des utilisateurs.

Implements

IServiceIrisObtenirUtilisateurs(Identite)
Examples
Exemple typique d'utilisation:
C#
VB
Copy
//Exemple à venir.
'Exemple à venir.
See Also

Reference

ServiceIris Class
CHUQ.CSCT.IRIS.Service Namespace


ServiceIris.Supprimer Method

ServiceIrisSupprimer Method

Méthode permettant de supprimer une réservation ou une occurence de réservation d'une série.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public void Supprimer(
    int identifiantPublic,
    Nullable<DateTime> dateHeureModificationInitiale,
    Identite identite,
    FuseauHoraire fuseauHoraire
)
Public Sub Supprimer (
    identifiantPublic As Integer,
    dateHeureModificationInitiale As Nullable(Of DateTime),
    identite As Identite,
    fuseauHoraire As FuseauHoraire
)

Parameters

identifiantPublic
Type: SystemInt32
Identifiant de la Réservation IRIS.
dateHeureModificationInitiale
Type: SystemNullableDateTime
Date et heure de la modification initiale.
identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.
fuseauHoraire
Type: CHUQ.CSCT.IRIS.Service.EnumerationsFuseauHoraire
Fuseau horaire Canadien.

Implements

IServiceIrisSupprimer(Int32, NullableDateTime, Identite, FuseauHoraire)
Remarks
La suppression s'effectue si l'utilisateur du service IRIS a les droits requis pour le faire.
Examples
Exemple typique d'utilisation:
C#
VB
Copy
const identifiantPublic = 1 //Numéro publique de la réservation IRIS que l'on désire supprimer.
const fuseauHoraire = CHUQ.CSCT.IRIS.Service.Enumeration.FuseauHoraire.Est //Fuseau horaire de la réservation à supprimer.
var identite = new CHUQ.CSCT.IRIS.Service.Modele.Identite {.Identifiant = "Code_Utilisateur",
                                                           .MotDePasse = "Mot_De_Passe",
                                                           .Domaine = DomaineActiveDirectory.Iris};
using service = new CHUQ.CSCT.IRIS.Service.ServiceIris() {
    service.open();
    service.Supprimer(identifiantPublic, Date.UtcNow, identite, fuseauHoraire);
}
Const identifiantPublic = 1 'Numéro publique de la réservation IRIS que l'on désire supprimer.
Const fuseauHoraire = CHUQ.CSCT.IRIS.Service.Enumeration.FuseauHoraire.Est 'Fuseau horaire de la réservation à supprimer.
Dim identite As New CHUQ.CSCT.IRIS.Service.Modele.Identite With {.Identifiant = "Code_Utilisateur",
                                                                 .MotDePasse = "Mot_De_Passe",
                                                                 .Domaine = DomaineActiveDirectory.Iris}
Using service As New CHUQ.CSCT.IRIS.Service.ServiceIris()
    service.open()
    service.Supprimer(identifiantPublic, Date.UtcNow, identite, fuseauHoraire)
End Using
See Also

Reference

ServiceIris Class
CHUQ.CSCT.IRIS.Service Namespace


ServiceIris.SupprimerSerie Method

ServiceIrisSupprimerSerie Method

Méthode permettant de supprimer une série de réservation IRIS.

Namespace: CHUQ.CSCT.IRIS.Service
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public void SupprimerSerie(
    int identifiantPublic,
    Nullable<DateTime> dateHeureModificationInitiale,
    Identite identite,
    FuseauHoraire fuseauHoraire
)
Public Sub SupprimerSerie (
    identifiantPublic As Integer,
    dateHeureModificationInitiale As Nullable(Of DateTime),
    identite As Identite,
    fuseauHoraire As FuseauHoraire
)

Parameters

identifiantPublic
Type: SystemInt32
Identifiant de la Réservation IRIS.
dateHeureModificationInitiale
Type: SystemNullableDateTime
Date et heure de la modification initiale.
identite
Type: CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite
Identité du client du service IRIS.
fuseauHoraire
Type: CHUQ.CSCT.IRIS.Service.EnumerationsFuseauHoraire
Fuseau horaire Canadien.

Implements

IServiceIrisSupprimerSerie(Int32, NullableDateTime, Identite, FuseauHoraire)
Remarks
La suppression s'effectue si l'utilisateur du service IRIS a les droits requis pour le faire. Il faut également que la réservation fournis soit bel et bien une série.
Examples
Exemple typique d'utilisation:
C#
VB
Copy
//Exemple à venir.
'Exemple à venir.
See Also

Reference

ServiceIris Class
CHUQ.CSCT.IRIS.Service Namespace


CHUQ.CSCT.IRIS.Service.Enumerations Namespace

CHUQ.CSCT.IRIS.Service.Enumerations Namespace

Espace de nom pour les énumérations.
Enumerations
 | Enumeration | Description
Public enumeration | DomaineActiveDirectory | Domaine Microsoft Active Directory.
Public enumeration | FuseauHoraire | Fuseau horaire Canadien.


DomaineActiveDirectory Enumeration

DomaineActiveDirectory Enumeration

Domaine Microsoft Active Directory.

Namespace: CHUQ.CSCT.IRIS.Service.Enumerations
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public enum DomaineActiveDirectory
Public Enumeration DomaineActiveDirectory
Members
Member name | Value | Description
Iris | 0 | Active Directory d'IRIS.
Sherbrooke | 1 | Active Directory de Sherbrooke.
Remarks
IRIS est en mesure de gérer des utilisateurs de différents domaines Active Directory. Chaque utilisateur pour être unique doivent obligatoirement faire partie de l'un des domaines suivants.
See Also

Reference

CHUQ.CSCT.IRIS.Service.Enumerations Namespace


FuseauHoraire Enumeration

FuseauHoraire Enumeration

Fuseau horaire Canadien.

Namespace: CHUQ.CSCT.IRIS.Service.Enumerations
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public enum FuseauHoraire
Public Enumeration FuseauHoraire
Members
Member name | Value | Description
Nst | 0 | Newfoundland Standard Time (NST) = UTC-3:30.
Ast | 1 | Atlantic Standard Time (AST) = UTC-4.
Est | 2 | Eastern Standard Time (EST) = UTC-5.
Cst | 3 | Central Standard Time (CST) = UTC-6.
Mst | 4 | Mountain Standard Time (MST) = UTC-7.
Pst | 5 | Pacific Standard Time (PST) = UTC -8.
See Also

Reference

CHUQ.CSCT.IRIS.Service.Enumerations Namespace


CHUQ.CSCT.IRIS.Service.Enumerations.Reservation Namespace

CHUQ.CSCT.IRIS.Service.Enumerations.Reservation Namespace

Espace de nom pour les énumérations de l'objet de réservation.
Enumerations
 | Enumeration | Description
Public enumeration | Accessibilite | Cet énumération sert à définir la portée d'une réservation.
Public enumeration | ModeAffichage | Mode d'affichage d'une visioconférence.
Public enumeration | PreTest | Période de prétest de la visioconférence.
Public enumeration | SousTypeReservation | Sous type de réservation IRIS.
Public enumeration | TypeConnexion | Type de connexion pour une visioconférence.


Accessibilite Enumeration

Accessibilite Enumeration

Cet énumération sert à définir la portée d'une réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Enumerations.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public enum Accessibilite
Public Enumeration Accessibilite
Members
Member name | Value | Description
Standard | 0 | Spécifie la réservation comme étant standard.
Publique | 1 | Spécifie la réservation comme étant publique.
Privee | 2 | Spécifie la réservation comme étant privée.
Remarks
Pour plus de détail, voir WIKI.
See Also

Reference

CHUQ.CSCT.IRIS.Service.Enumerations.Reservation Namespace


ModeAffichage Enumeration

ModeAffichage Enumeration

Mode d'affichage d'une visioconférence.

Namespace: CHUQ.CSCT.IRIS.Service.Enumerations.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public enum ModeAffichage
Public Enumeration ModeAffichage
Members
Member name | Value | Description
PresenceContinue | 0 | Présence continue.
AmeliorationPresenceContinue | 1 | Amélioration Présence Continue.
CommutationVocale | 2 | Commutation vocale.
See Also

Reference

CHUQ.CSCT.IRIS.Service.Enumerations.Reservation Namespace


PreTest Enumeration

PreTest Enumeration

Période de prétest de la visioconférence.

Namespace: CHUQ.CSCT.IRIS.Service.Enumerations.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public enum PreTest
Public Enumeration PreTest
Members
Member name | Value | Description
Aucune | 0 | Aucune période de prétest.
Min05 | 5 | 5 minutes de prétest.
Min10 | 10 | 10 minutes de prétest.
Min15 | 15 | 15 minutes de prétest.
Min20 | 20 | 20 minutes de prétest.
Min25 | 25 | 25 minutes de prétest.
Min30 | 30 | 30 minutes de prétest.
See Also

Reference

CHUQ.CSCT.IRIS.Service.Enumerations.Reservation Namespace


SousTypeReservation Enumeration

SousTypeReservation Enumeration

Sous type de réservation IRIS.

Namespace: CHUQ.CSCT.IRIS.Service.Enumerations.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public enum SousTypeReservation
Public Enumeration SousTypeReservation
Members
Member name | Value | Description
AvecPatient | 0 | Avec patient.
SansPatient | 1 | Sans patient.
See Also

Reference

CHUQ.CSCT.IRIS.Service.Enumerations.Reservation Namespace


TypeConnexion Enumeration

TypeConnexion Enumeration

Type de connexion pour une visioconférence.

Namespace: CHUQ.CSCT.IRIS.Service.Enumerations.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public enum TypeConnexion
Public Enumeration TypeConnexion
Members
Member name | Value | Description
ReservationSeulement | 0 | Réservation seulement.
LancementAutomatique | 1 | Lancement automatique.
LancementManuel | 2 | Lancement manuel.
Remarks
Dans les faits les TMS utilisés par IRIS supportent plusieurs autre type de connexion, mais seul ces types de connexion sont pris en charge par IRIS.
See Also

Reference

CHUQ.CSCT.IRIS.Service.Enumerations.Reservation Namespace


CHUQ.CSCT.IRIS.Service.Enumerations.Reservation.Recurrence Namespace

CHUQ.CSCT.IRIS.Service.Enumerations.Reservation.Recurrence Namespace

[Ceci est une documentation préliminaire, sous réserve de modification.]

Espace de nom pour les énumérations pour l'objet de récurrence.
Enumerations
 | Enumeration | Description
Public enumeration | Periodes | Période d'une récurrence.
Public enumeration | TypeFin | Type de fin d'une récurrence.
Public enumeration | TypeFrequence | Type de fréquence d'une récurrence.
Public enumeration | TypePositionInstance | Position de l'instance (ex: à tous les X jours).


Periodes Enumeration

Periodes Enumeration

Période d'une récurrence.

Namespace: CHUQ.CSCT.IRIS.Service.Enumerations.Reservation.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum Periodes
<FlagsAttribute>
Public Enumeration Periodes
Members
Member name | Value | Description
Aucune | 0 | Aucune.
Dimanche | 1 | Tous les dimanches.
Lundi | 2 | Tous les lundis.
Mardi | 4 | Tous les mardis.
Mercredi | 8 | Tous les mercredis.
Jeudi | 16 | Tous les jeudis.
Vendredi | 32 | Tous les vendredis.
JoursSemaine | 62 | Les jours de semaine (Du lundi au vendredi).
Samedi | 64 | Tous les samedis.
JoursFinSemaine | 65 | Les jours de fin de semaine (Samedi et dimanche)
ChaqueJour | 127 | Chaque jour de la semaine.
Remarks
See Also

Reference

CHUQ.CSCT.IRIS.Service.Enumerations.Reservation.Recurrence Namespace


TypeFin Enumeration

TypeFin Enumeration

Type de fin d'une récurrence.

Namespace: CHUQ.CSCT.IRIS.Service.Enumerations.Reservation.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public enum TypeFin
Public Enumeration TypeFin
Members
Member name | Value | Description
ParDate | 0 | Fin de récurrence par date de fin.
ParNombreInstances | 1 | Fin de récurrence par un nombre d'instances.
Remarks
See Also

Reference

CHUQ.CSCT.IRIS.Service.Enumerations.Reservation.Recurrence Namespace


TypeFrequence Enumeration

TypeFrequence Enumeration

Type de fréquence d'une récurrence.

Namespace: CHUQ.CSCT.IRIS.Service.Enumerations.Reservation.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public enum TypeFrequence
Public Enumeration TypeFrequence
Members
Member name | Value | Description
Quotidienne | 0 | Fréquence quotidienne.
Hebdomadaire | 1 | Fréquence hebdomadaire.
Mensuelle | 2 | Fréquence mensuelle.
Remarks
See Also

Reference

CHUQ.CSCT.IRIS.Service.Enumerations.Reservation.Recurrence Namespace


TypePositionInstance Enumeration

TypePositionInstance Enumeration

Position de l'instance (ex: à tous les X jours).

Namespace: CHUQ.CSCT.IRIS.Service.Enumerations.Reservation.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public enum TypePositionInstance
Public Enumeration TypePositionInstance
Members
Member name | Value | Description
Aucun | 0 | Aucun.
Premier | 1 | Premier.
Second | 2 | Second.
Troisieme | 3 | Troisième.
Quatrieme | 4 | Quatrième.
Dernier | -1 | Dernier.
See Also

Reference

CHUQ.CSCT.IRIS.Service.Enumerations.Reservation.Recurrence Namespace


CHUQ.CSCT.IRIS.Service.Exceptions Namespace

CHUQ.CSCT.IRIS.Service.Exceptions Namespace

Espace de nom pour les exceptions.
Classes
 | Class | Description
Public class | IrisException | Les IrisException sont des validations fonctionnelles.
Public class | SystemeIrisException | Les SystemeIrisException ne devrait en principe jamais être levé, ce type d'exception sert à aviser le client qu'une erreur interne s'est produite à l'intérieur du Service IRIS pour un cas n'ayant pas été correctement géré.


IrisException Class

IrisException Class

Les IrisException sont des validations fonctionnelles.
Inheritance Hierarchy
SystemObject
ErreurFonctionnelle
CHUQ.CSCT.IRIS.Service.ExceptionsIrisException

Namespace: CHUQ.CSCT.IRIS.Service.Exceptions
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public class IrisException : ErreurFonctionnelle
Public Class IrisException
    Inherits ErreurFonctionnelle

The IrisException type exposes the following members.

Constructors
 | Name | Description
Public method | IrisException | Constructeur de l'objet.
Top
Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Code | (Inherited from ErreurFonctionnelle.)
Public property | Message | (Inherited from ErreurFonctionnelle.)
Top
See Also

Reference

CHUQ.CSCT.IRIS.Service.Exceptions Namespace


IrisException Constructor

IrisException Constructor

Constructeur de l'objet.

Namespace: CHUQ.CSCT.IRIS.Service.Exceptions
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public IrisException(
    int code,
    string message
)
Public Sub New (
    code As Integer,
    message As String
)

Parameters

code
Type: SystemInt32
Code d'erreur.
message
Type: SystemString
Message d'erreur.
See Also

Reference

IrisException Class
CHUQ.CSCT.IRIS.Service.Exceptions Namespace


IrisException Methods

IrisException Methods

The IrisException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
See Also

Reference

IrisException Class
CHUQ.CSCT.IRIS.Service.Exceptions Namespace


IrisException Properties

IrisException Properties

The IrisException type exposes the following members.

Properties
 | Name | Description
Public property | Code | (Inherited from ErreurFonctionnelle.)
Public property | Message | (Inherited from ErreurFonctionnelle.)
Top
See Also

Reference

IrisException Class
CHUQ.CSCT.IRIS.Service.Exceptions Namespace


SystemeIrisException Class

SystemeIrisException Class

Les SystemeIrisException ne devrait en principe jamais être levé, ce type d'exception sert à aviser le client qu'une erreur interne s'est produite à l'intérieur du Service IRIS pour un cas n'ayant pas été correctement géré.
Inheritance Hierarchy
SystemObject
ErreurSysteme
CHUQ.CSCT.IRIS.Service.ExceptionsSystemeIrisException

Namespace: CHUQ.CSCT.IRIS.Service.Exceptions
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public class SystemeIrisException : ErreurSysteme
Public Class SystemeIrisException
    Inherits ErreurSysteme

The SystemeIrisException type exposes the following members.

Constructors
 | Name | Description
Public method | SystemeIrisException | Constructeur de l'objet.
Top
Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Code | (Inherited from ErreurSysteme.)
Public property | Message | (Inherited from ErreurSysteme.)
Top
See Also

Reference

CHUQ.CSCT.IRIS.Service.Exceptions Namespace


SystemeIrisException Constructor

SystemeIrisException Constructor

Constructeur de l'objet.

Namespace: CHUQ.CSCT.IRIS.Service.Exceptions
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public SystemeIrisException(
    int code,
    string message
)
Public Sub New (
    code As Integer,
    message As String
)

Parameters

code
Type: SystemInt32
Code d'erreur.
message
Type: SystemString
Message d'erreur.
See Also

Reference

SystemeIrisException Class
CHUQ.CSCT.IRIS.Service.Exceptions Namespace


SystemeIrisException Methods

SystemeIrisException Methods

The SystemeIrisException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
See Also

Reference

SystemeIrisException Class
CHUQ.CSCT.IRIS.Service.Exceptions Namespace


SystemeIrisException Properties

SystemeIrisException Properties

The SystemeIrisException type exposes the following members.

Properties
 | Name | Description
Public property | Code | (Inherited from ErreurSysteme.)
Public property | Message | (Inherited from ErreurSysteme.)
Top
See Also

Reference

SystemeIrisException Class
CHUQ.CSCT.IRIS.Service.Exceptions Namespace


CHUQ.CSCT.IRIS.Service.Modele.Activite Namespace

CHUQ.CSCT.IRIS.Service.Modele.Activite Namespace

Espace de nom pour l'entité activité.
Classes
 | Class | Description
Public class | Activite | Cette classe représente une activité de réservation IRIS.
Interfaces
 | Interface | Description
Public interface | IActivite | Cet interface représente une activité de réservation IRIS.


Activite Class

Activite Class

Cette classe représente une activité de réservation IRIS.
Inheritance Hierarchy
SystemObject
CHUQ.CSCT.IRIS.Service.Modele.ActiviteActivite

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Activite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public class Activite : IActivite
Public Class Activite
    Implements IActivite

The Activite type exposes the following members.

Constructors
 | Name | Description
Public method | Activite | Initializes a new instance of the Activite class
Top
Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Identifiant | Identifiant d'une activité.
Public property | Nom | Nom de l'activité.
Top
Remarks
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Activite Namespace


Activite Constructor

Activite Constructor

Initializes a new instance of the Activite class

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Activite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Activite()
Public Sub New
See Also

Reference

Activite Class
CHUQ.CSCT.IRIS.Service.Modele.Activite Namespace


Activite Methods

Activite Methods

The Activite type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
See Also

Reference

Activite Class
CHUQ.CSCT.IRIS.Service.Modele.Activite Namespace


Activite Properties

Activite Properties

The Activite type exposes the following members.

Properties
 | Name | Description
Public property | Identifiant | Identifiant d'une activité.
Public property | Nom | Nom de l'activité.
Top
See Also

Reference

Activite Class
CHUQ.CSCT.IRIS.Service.Modele.Activite Namespace


Activite.Identifiant Property

ActiviteIdentifiant Property

Identifiant d'une activité.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Activite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public int Identifiant { get; set; }
Public Property Identifiant As Integer
    Get
    Set

Return Value

Type: Int32
L'identifiant d'une activité.

Implements

IActiviteIdentifiant
See Also

Reference

Activite Class
CHUQ.CSCT.IRIS.Service.Modele.Activite Namespace


Activite.Nom Property

ActiviteNom Property

Nom de l'activité.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Activite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string Nom { get; set; }
Public Property Nom As String
    Get
    Set

Return Value

Type: String
Nom de l'activité.

Implements

IActiviteNom
See Also

Reference

Activite Class
CHUQ.CSCT.IRIS.Service.Modele.Activite Namespace


IActivite Interface

IActivite Interface

Cet interface représente une activité de réservation IRIS.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Activite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public interface IActivite
Public Interface IActivite

The IActivite type exposes the following members.

Properties
 | Name | Description
Public property | Identifiant | Identifiant d'une activité.
Public property | Nom | Nom de l'activité.
Top
Remarks
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Activite Namespace


IActivite Properties

IActivite Properties

The IActivite type exposes the following members.

Properties
 | Name | Description
Public property | Identifiant | Identifiant d'une activité.
Public property | Nom | Nom de l'activité.
Top
See Also

Reference

IActivite Interface
CHUQ.CSCT.IRIS.Service.Modele.Activite Namespace


IActivite.Identifiant Property

IActiviteIdentifiant Property

Identifiant d'une activité.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Activite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
int Identifiant { get; set; }
Property Identifiant As Integer
    Get
    Set

Return Value

Type: Int32
Identifiant d'une activité.
See Also

Reference

IActivite Interface
CHUQ.CSCT.IRIS.Service.Modele.Activite Namespace


IActivite.Nom Property

IActiviteNom Property

Nom de l'activité.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Activite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string Nom { get; set; }
Property Nom As String
    Get
    Set

Return Value

Type: String
Nom de l'activité.
See Also

Reference

IActivite Interface
CHUQ.CSCT.IRIS.Service.Modele.Activite Namespace


CHUQ.CSCT.IRIS.Service.Modele.Identite Namespace

CHUQ.CSCT.IRIS.Service.Modele.Identite Namespace

Espace de nom pour l'entité identité.
Classes
 | Class | Description
Public class | Identite | Identité d'un utilisateur.
Interfaces
 | Interface | Description
Public interface | IIdentite | Cet interface représente une identité IRIS.


Identite Class

Identite Class

Identité d'un utilisateur.
Inheritance Hierarchy
SystemObject
CHUQ.CSCT.IRIS.Service.Modele.IdentiteIdentite

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Identite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public class Identite : IIdentite
Public Class Identite
    Implements IIdentite

The Identite type exposes the following members.

Constructors
 | Name | Description
Public method | Identite | Initializes a new instance of the Identite class
Top
Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Domaine | Le domaine Active Directory de l'utilisateur.
Public property | IdentifiantUtilisateur | Code de l'utilisateur.
Public property | MotPasse | Le mot de passe de l'utilisateur.
Top
Remarks
Cet entité sert pour l'authentification au service IRIS.
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Identite Namespace


Identite Constructor

Identite Constructor

Initializes a new instance of the Identite class

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Identite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Identite()
Public Sub New
See Also

Reference

Identite Class
CHUQ.CSCT.IRIS.Service.Modele.Identite Namespace


Identite Methods

Identite Methods

The Identite type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
See Also

Reference

Identite Class
CHUQ.CSCT.IRIS.Service.Modele.Identite Namespace


Identite Properties

Identite Properties

The Identite type exposes the following members.

Properties
 | Name | Description
Public property | Domaine | Le domaine Active Directory de l'utilisateur.
Public property | IdentifiantUtilisateur | Code de l'utilisateur.
Public property | MotPasse | Le mot de passe de l'utilisateur.
Top
See Also

Reference

Identite Class
CHUQ.CSCT.IRIS.Service.Modele.Identite Namespace


Identite.Domaine Property

IdentiteDomaine Property

Le domaine Active Directory de l'utilisateur.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Identite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public DomaineActiveDirectory Domaine { get; set; }
Public Property Domaine As DomaineActiveDirectory
    Get
    Set

Return Value

Type: DomaineActiveDirectory
Le domaine Active Directory de l'utilisateur.

Implements

IUtilisateurBaseDomaine
See Also

Reference

Identite Class
CHUQ.CSCT.IRIS.Service.Modele.Identite Namespace


Identite.IdentifiantUtilisateur Property

IdentiteIdentifiantUtilisateur Property

Code de l'utilisateur.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Identite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string IdentifiantUtilisateur { get; set; }
Public Property IdentifiantUtilisateur As String
    Get
    Set

Return Value

Type: String
Code de l'utilisateur.

Implements

IUtilisateurBaseIdentifiantUtilisateur
See Also

Reference

Identite Class
CHUQ.CSCT.IRIS.Service.Modele.Identite Namespace


Identite.MotPasse Property

IdentiteMotPasse Property

Le mot de passe de l'utilisateur.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Identite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string MotPasse { get; set; }
Public Property MotPasse As String
    Get
    Set

Return Value

Type: String
Le mot de passe de l'utilisateur.

Implements

IIdentiteMotPasse
See Also

Reference

Identite Class
CHUQ.CSCT.IRIS.Service.Modele.Identite Namespace


IIdentite Interface

IIdentite Interface

Cet interface représente une identité IRIS.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Identite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public interface IIdentite : IUtilisateurBase
Public Interface IIdentite
    Inherits IUtilisateurBase

The IIdentite type exposes the following members.

Properties
 | Name | Description
Public property | Domaine | Domaine Active Directory. (Inherited from IUtilisateurBase.)
Public property | IdentifiantUtilisateur | Code utilisateur. (Inherited from IUtilisateurBase.)
Public property | MotPasse | Mot de passe de l'utilisateur.
Top
Remarks
Cet interface sert pour l'authentification au service IRIS.
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Identite Namespace


IIdentite Properties

IIdentite Properties

The IIdentite type exposes the following members.

Properties
 | Name | Description
Public property | Domaine | Domaine Active Directory. (Inherited from IUtilisateurBase.)
Public property | IdentifiantUtilisateur | Code utilisateur. (Inherited from IUtilisateurBase.)
Public property | MotPasse | Mot de passe de l'utilisateur.
Top
See Also

Reference

IIdentite Interface
CHUQ.CSCT.IRIS.Service.Modele.Identite Namespace


IIdentite.MotPasse Property

IIdentiteMotPasse Property

Mot de passe de l'utilisateur.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Identite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string MotPasse { get; set; }
Property MotPasse As String
    Get
    Set

Return Value

Type: String
Mot de passe de l'utilisateur.
See Also

Reference

IIdentite Interface
CHUQ.CSCT.IRIS.Service.Modele.Identite Namespace


CHUQ.CSCT.IRIS.Service.Modele.Installation Namespace

CHUQ.CSCT.IRIS.Service.Modele.Installation Namespace

Espace de nom pour l'entité installation (établissement).
Classes
 | Class | Description
Public class | Installation | Cette classe représente un installation pris en charge par IRIS.
Interfaces
 | Interface | Description
Public interface | IInstallation | Cet interface représente un installation pris en charge par IRIS.


IInstallation Interface

IInstallation Interface

Cet interface représente un installation pris en charge par IRIS.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Installation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public interface IInstallation
Public Interface IInstallation

The IInstallation type exposes the following members.

Properties
 | Name | Description
Public property | Identifiant | Identifiant d'une installation.
Public property | Nom | Le nom de l'installation (Établissement).
Top
Remarks
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Installation Namespace


IInstallation Properties

IInstallation Properties

The IInstallation type exposes the following members.

Properties
 | Name | Description
Public property | Identifiant | Identifiant d'une installation.
Public property | Nom | Le nom de l'installation (Établissement).
Top
See Also

Reference

IInstallation Interface
CHUQ.CSCT.IRIS.Service.Modele.Installation Namespace


IInstallation.Identifiant Property

IInstallationIdentifiant Property

Identifiant d'une installation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Installation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
int Identifiant { get; set; }
Property Identifiant As Integer
    Get
    Set

Return Value

Type: Int32
L'identifiant d'une installation.
See Also

Reference

IInstallation Interface
CHUQ.CSCT.IRIS.Service.Modele.Installation Namespace


IInstallation.Nom Property

IInstallationNom Property

Le nom de l'installation (Établissement).

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Installation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string Nom { get; set; }
Property Nom As String
    Get
    Set

Return Value

Type: String
Le nom de l'installation (Établissement).
See Also

Reference

IInstallation Interface
CHUQ.CSCT.IRIS.Service.Modele.Installation Namespace


Installation Class

Installation Class

Cette classe représente un installation pris en charge par IRIS.
Inheritance Hierarchy
SystemObject
CHUQ.CSCT.IRIS.Service.Modele.InstallationInstallation

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Installation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public class Installation : IInstallation
Public Class Installation
    Implements IInstallation

The Installation type exposes the following members.

Constructors
 | Name | Description
Public method | Installation | Initializes a new instance of the Installation class
Top
Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Identifiant | Identifiant d'une installation.
Public property | Nom | Le nom de l'installation (Établissement).
Top
Remarks
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Installation Namespace


Installation Constructor

Installation Constructor

Initializes a new instance of the Installation class

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Installation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Installation()
Public Sub New
See Also

Reference

Installation Class
CHUQ.CSCT.IRIS.Service.Modele.Installation Namespace


Installation Methods

Installation Methods

The Installation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
See Also

Reference

Installation Class
CHUQ.CSCT.IRIS.Service.Modele.Installation Namespace


Installation Properties

Installation Properties

The Installation type exposes the following members.

Properties
 | Name | Description
Public property | Identifiant | Identifiant d'une installation.
Public property | Nom | Le nom de l'installation (Établissement).
Top
See Also

Reference

Installation Class
CHUQ.CSCT.IRIS.Service.Modele.Installation Namespace


Installation.Identifiant Property

InstallationIdentifiant Property

Identifiant d'une installation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Installation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public int Identifiant { get; set; }
Public Property Identifiant As Integer
    Get
    Set

Return Value

Type: Int32
L'identifiant d'une installation.

Implements

IInstallationIdentifiant
See Also

Reference

Installation Class
CHUQ.CSCT.IRIS.Service.Modele.Installation Namespace


Installation.Nom Property

InstallationNom Property

Le nom de l'installation (Établissement).

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Installation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string Nom { get; set; }
Public Property Nom As String
    Get
    Set

Return Value

Type: String
Le nom de l'installation (Établissement).

Implements

IInstallationNom
See Also

Reference

Installation Class
CHUQ.CSCT.IRIS.Service.Modele.Installation Namespace


CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace

CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace

Espace de nom pour l'entité de récurrence.
Classes
 | Class | Description
Public class | PatronRecurrence | Patron de récurrence pour une réservation IRIS.
Interfaces
 | Interface | Description
Public interface | IPatronRecurrence | Patron de récurrence pour une réservation IRIS.


IPatronRecurrence Interface

IPatronRecurrence Interface

Patron de récurrence pour une réservation IRIS.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public interface IPatronRecurrence
Public Interface IPatronRecurrence

The IPatronRecurrence type exposes the following members.

Properties
 | Name | Description
Public property | DateDebut | Date et heure de début UTC.
Public property | DateFin | Date et heure de fin UTC.
Public property | Duree | Durée.
Public property | ExceptionDates | Liste de dates exclus pour une récurrence.
Public property | HeureDebut | Heure de début.
Public property | HeureFin | Heure de fin.
Public property | Intervalle | Intervalle.
Public property | MasquePeriode | Masque de période.
Public property | NombreInstances | Nombre d'instances pour une récurrence dont le type de fin est par nombre d'instance.
Public property | PositionInstance | Position de l'instance de récurrence.
Public property | TypeFin | Type de fin de la récurrence.
Public property | TypeFrequence | Type de fréquence.
Top
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


IPatronRecurrence Properties

IPatronRecurrence Properties

The IPatronRecurrence type exposes the following members.

Properties
 | Name | Description
Public property | DateDebut | Date et heure de début UTC.
Public property | DateFin | Date et heure de fin UTC.
Public property | Duree | Durée.
Public property | ExceptionDates | Liste de dates exclus pour une récurrence.
Public property | HeureDebut | Heure de début.
Public property | HeureFin | Heure de fin.
Public property | Intervalle | Intervalle.
Public property | MasquePeriode | Masque de période.
Public property | NombreInstances | Nombre d'instances pour une récurrence dont le type de fin est par nombre d'instance.
Public property | PositionInstance | Position de l'instance de récurrence.
Public property | TypeFin | Type de fin de la récurrence.
Public property | TypeFrequence | Type de fréquence.
Top
See Also

Reference

IPatronRecurrence Interface
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


IPatronRecurrence.DateDebut Property

IPatronRecurrenceDateDebut Property

Date et heure de début UTC.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Nullable<DateTime> DateDebut { get; set; }
Property DateDebut As Nullable(Of DateTime)
    Get
    Set

Return Value

Type: NullableDateTime
Date et heure de début UTC.
See Also

Reference

IPatronRecurrence Interface
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


IPatronRecurrence.DateFin Property

IPatronRecurrenceDateFin Property

Date et heure de fin UTC.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Nullable<DateTime> DateFin { get; set; }
Property DateFin As Nullable(Of DateTime)
    Get
    Set

Return Value

Type: NullableDateTime
Date et heure de fin UTC.
See Also

Reference

IPatronRecurrence Interface
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


IPatronRecurrence.Duree Property

IPatronRecurrenceDuree Property

Durée.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
TimeSpan Duree { get; set; }
Property Duree As TimeSpan
    Get
    Set

Return Value

Type: TimeSpan
Durée.
See Also

Reference

IPatronRecurrence Interface
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


IPatronRecurrence.ExceptionDates Property

IPatronRecurrenceExceptionDates Property

Liste de dates exclus pour une récurrence.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
List<DateTime> ExceptionDates { get; set; }
Property ExceptionDates As List(Of DateTime)
    Get
    Set

Return Value

Type: ListDateTime
Liste de dates exclus pour une récurrence.
Remarks
Les dates doivent être fournis en UTC.
See Also

Reference

IPatronRecurrence Interface
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


IPatronRecurrence.HeureDebut Property

IPatronRecurrenceHeureDebut Property

Heure de début.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
TimeSpan HeureDebut { get; set; }
Property HeureDebut As TimeSpan
    Get
    Set

Return Value

Type: TimeSpan
Heure de début.
See Also

Reference

IPatronRecurrence Interface
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


IPatronRecurrence.HeureFin Property

IPatronRecurrenceHeureFin Property

Heure de fin.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Nullable<TimeSpan> HeureFin { get; set; }
Property HeureFin As Nullable(Of TimeSpan)
    Get
    Set

Return Value

Type: NullableTimeSpan
Heure de fin.
See Also

Reference

IPatronRecurrence Interface
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


IPatronRecurrence.Intervalle Property

IPatronRecurrenceIntervalle Property

Intervalle.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
int Intervalle { get; set; }
Property Intervalle As Integer
    Get
    Set

Return Value

Type: Int32
Intervalle.
See Also

Reference

IPatronRecurrence Interface
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


IPatronRecurrence.MasquePeriode Property

IPatronRecurrenceMasquePeriode Property

Masque de période.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Periodes MasquePeriode { get; set; }
Property MasquePeriode As Periodes
    Get
    Set

Return Value

Type: Periodes
Masque de période.
See Also

Reference

IPatronRecurrence Interface
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


IPatronRecurrence.NombreInstances Property

IPatronRecurrenceNombreInstances Property

Nombre d'instances pour une récurrence dont le type de fin est par nombre d'instance.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
int NombreInstances { get; set; }
Property NombreInstances As Integer
    Get
    Set

Return Value

Type: Int32
Nombre d'instances pour une récurrence dont le type de fin est par nombre d'instance.
See Also

Reference

IPatronRecurrence Interface
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


IPatronRecurrence.PositionInstance Property

IPatronRecurrencePositionInstance Property

Position de l'instance de récurrence.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
TypePositionInstance PositionInstance { get; set; }
Property PositionInstance As TypePositionInstance
    Get
    Set

Return Value

Type: TypePositionInstance
Position de l'instance de récurrence.
See Also

Reference

IPatronRecurrence Interface
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


IPatronRecurrence.TypeFin Property

IPatronRecurrenceTypeFin Property

Type de fin de la récurrence.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
TypeFin TypeFin { get; set; }
Property TypeFin As TypeFin
    Get
    Set

Return Value

Type: TypeFin
Type de fin de la récurrence.
See Also

Reference

IPatronRecurrence Interface
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


IPatronRecurrence.TypeFrequence Property

IPatronRecurrenceTypeFrequence Property

Type de fréquence.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
TypeFrequence TypeFrequence { get; set; }
Property TypeFrequence As TypeFrequence
    Get
    Set

Return Value

Type: TypeFrequence
Type de fréquence.
See Also

Reference

IPatronRecurrence Interface
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


PatronRecurrence Class

PatronRecurrence Class

Patron de récurrence pour une réservation IRIS.
Inheritance Hierarchy
SystemObject
CHUQ.CSCT.IRIS.Service.Modele.RecurrencePatronRecurrence

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public class PatronRecurrence : IPatronRecurrence
Public Class PatronRecurrence
    Implements IPatronRecurrence

The PatronRecurrence type exposes the following members.

Constructors
 | Name | Description
Public method | PatronRecurrence | Initializes a new instance of the PatronRecurrence class
Top
Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DateDebut | Date et heure de début UTC.
Public property | DateFin | Date et heure de fin UTC.
Public property | Duree | Durée.
Public property | ExceptionDates | Liste de dates exclus pour une récurrence.
Public property | HeureDebut | Heure de début.
Public property | HeureFin | Heure de fin.
Public property | Intervalle | Intervalle.
Public property | MasquePeriode | Masque de période.
Public property | NombreInstances | Nombre d'instances pour une récurrence dont le type de fin est par nombre d'instance.
Public property | PositionInstance | Position de l'instance de récurrence.
Public property | TypeFin | Type de fin de la récurrence.
Public property | TypeFrequence | Type de fréquence.
Top
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


PatronRecurrence Constructor

PatronRecurrence Constructor

Initializes a new instance of the PatronRecurrence class

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public PatronRecurrence()
Public Sub New
See Also

Reference

PatronRecurrence Class
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


PatronRecurrence Methods

PatronRecurrence Methods

The PatronRecurrence type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
See Also

Reference

PatronRecurrence Class
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


PatronRecurrence Properties

PatronRecurrence Properties

The PatronRecurrence type exposes the following members.

Properties
 | Name | Description
Public property | DateDebut | Date et heure de début UTC.
Public property | DateFin | Date et heure de fin UTC.
Public property | Duree | Durée.
Public property | ExceptionDates | Liste de dates exclus pour une récurrence.
Public property | HeureDebut | Heure de début.
Public property | HeureFin | Heure de fin.
Public property | Intervalle | Intervalle.
Public property | MasquePeriode | Masque de période.
Public property | NombreInstances | Nombre d'instances pour une récurrence dont le type de fin est par nombre d'instance.
Public property | PositionInstance | Position de l'instance de récurrence.
Public property | TypeFin | Type de fin de la récurrence.
Public property | TypeFrequence | Type de fréquence.
Top
See Also

Reference

PatronRecurrence Class
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


PatronRecurrence.DateDebut Property

PatronRecurrenceDateDebut Property

Date et heure de début UTC.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Nullable<DateTime> DateDebut { get; set; }
Public Property DateDebut As Nullable(Of DateTime)
    Get
    Set

Return Value

Type: NullableDateTime
Date et heure de début UTC.

Implements

IPatronRecurrenceDateDebut
See Also

Reference

PatronRecurrence Class
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


PatronRecurrence.DateFin Property

PatronRecurrenceDateFin Property

Date et heure de fin UTC.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Nullable<DateTime> DateFin { get; set; }
Public Property DateFin As Nullable(Of DateTime)
    Get
    Set

Return Value

Type: NullableDateTime
Date et heure de fin UTC.

Implements

IPatronRecurrenceDateFin
See Also

Reference

PatronRecurrence Class
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


PatronRecurrence.Duree Property

PatronRecurrenceDuree Property

Durée.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public TimeSpan Duree { get; set; }
Public Property Duree As TimeSpan
    Get
    Set

Return Value

Type: TimeSpan
Durée.

Implements

IPatronRecurrenceDuree
See Also

Reference

PatronRecurrence Class
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


PatronRecurrence.ExceptionDates Property

PatronRecurrenceExceptionDates Property

Liste de dates exclus pour une récurrence.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public List<DateTime> ExceptionDates { get; set; }
Public Property ExceptionDates As List(Of DateTime)
    Get
    Set

Return Value

Type: ListDateTime
Liste de dates exclus pour une récurrence.

Implements

IPatronRecurrenceExceptionDates
Remarks
Les dates doivent être fournis en UTC.
See Also

Reference

PatronRecurrence Class
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


PatronRecurrence.HeureDebut Property

PatronRecurrenceHeureDebut Property

Heure de début.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public TimeSpan HeureDebut { get; set; }
Public Property HeureDebut As TimeSpan
    Get
    Set

Return Value

Type: TimeSpan
Heure de début.

Implements

IPatronRecurrenceHeureDebut
See Also

Reference

PatronRecurrence Class
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


PatronRecurrence.HeureFin Property

PatronRecurrenceHeureFin Property

Heure de fin.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Nullable<TimeSpan> HeureFin { get; set; }
Public Property HeureFin As Nullable(Of TimeSpan)
    Get
    Set

Return Value

Type: NullableTimeSpan
Heure de fin.

Implements

IPatronRecurrenceHeureFin
See Also

Reference

PatronRecurrence Class
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


PatronRecurrence.Intervalle Property

PatronRecurrenceIntervalle Property

Intervalle.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public int Intervalle { get; set; }
Public Property Intervalle As Integer
    Get
    Set

Return Value

Type: Int32
Intervalle.

Implements

IPatronRecurrenceIntervalle
See Also

Reference

PatronRecurrence Class
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


PatronRecurrence.MasquePeriode Property

PatronRecurrenceMasquePeriode Property

Masque de période.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Periodes MasquePeriode { get; set; }
Public Property MasquePeriode As Periodes
    Get
    Set

Return Value

Type: Periodes
Masque de période.

Implements

IPatronRecurrenceMasquePeriode
See Also

Reference

PatronRecurrence Class
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


PatronRecurrence.NombreInstances Property

PatronRecurrenceNombreInstances Property

Nombre d'instances pour une récurrence dont le type de fin est par nombre d'instance.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public int NombreInstances { get; set; }
Public Property NombreInstances As Integer
    Get
    Set

Return Value

Type: Int32
Nombre d'instances pour une récurrence dont le type de fin est par nombre d'instance.

Implements

IPatronRecurrenceNombreInstances
See Also

Reference

PatronRecurrence Class
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


PatronRecurrence.PositionInstance Property

PatronRecurrencePositionInstance Property

Position de l'instance de récurrence.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public TypePositionInstance PositionInstance { get; set; }
Public Property PositionInstance As TypePositionInstance
    Get
    Set

Return Value

Type: TypePositionInstance
Position de l'instance de récurrence.

Implements

IPatronRecurrencePositionInstance
See Also

Reference

PatronRecurrence Class
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


PatronRecurrence.TypeFin Property

PatronRecurrenceTypeFin Property

Type de fin de la récurrence.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public TypeFin TypeFin { get; set; }
Public Property TypeFin As TypeFin
    Get
    Set

Return Value

Type: TypeFin
Type de fin de la récurrence.

Implements

IPatronRecurrenceTypeFin
See Also

Reference

PatronRecurrence Class
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


PatronRecurrence.TypeFrequence Property

PatronRecurrenceTypeFrequence Property

Type de fréquence.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Recurrence
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public TypeFrequence TypeFrequence { get; set; }
Public Property TypeFrequence As TypeFrequence
    Get
    Set

Return Value

Type: TypeFrequence
Type de fréquence.

Implements

IPatronRecurrenceTypeFrequence
See Also

Reference

PatronRecurrence Class
CHUQ.CSCT.IRIS.Service.Modele.Recurrence Namespace


CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace

CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace

Espace de nom pour l'entité réservation.
Classes
 | Class | Description
Public class | Reservation | Cette classe représente une réservation IRIS.
Interfaces
 | Interface | Description
Public interface | IReservation | Cet interface représente une réservation IRIS.


IReservation Interface

IReservation Interface

Cet interface représente une réservation IRIS.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public interface IReservation
Public Interface IReservation

The IReservation type exposes the following members.

Properties
 | Name | Description
Public property | Accessibilite | L'accessibilité de la réservation.
Public property | Accreditation | L'accréditation pour la réservation.
Public property | ActivitePayante | Activité payante.
Public property | CodeFacturation | Code de facturation.
Public property | Commentaire | Commentaire de la réservation.
Public property | Conferencier | Nom du conférencier.
Public property | DateDebut | Date et heure de début de la réservation en UTC.
Public property | DateFin | Date et heure de fin de la réservation en UTC.
Public property | DateModification | Date et heure UTC de modification de la réservation.
Public property | Description | Description de la réservation.
Public property | DescriptionAccreditation | Description de l'accréditation.
Public property | DescriptionActivitePayante | Description de l'activité payante.
Public property | IdentifiantActivite | Activité de la réservation.
Public property | IdentifiantInstallationOrganisateur | Installation (Établissement/Site) Organisateur.
Public property | IdentifiantPontNational | Numéro de la réservation de visioconférence sur le Pont National.
Public property | IdentifiantReservationPublic | Numéro unique concernant une réservation IRIS.
Public property | IdentifiantSourceExterne | Identifiant de la source Externe.
Public property | IdentifiantSpecialite | Spécialité de la réservation.
Public property | ModeAffichage | Mode d'affichage de la réservation de visioconférence.
Public property | NombreIntervenant | Le nombre d'intervenants pour la réservation.
Public property | NombrePatient | Le nombre de patients de la réservation pour une réservation Avec Patient.
Public property | NomInstallationOrganisateurAutre | Nom de l'installation (Établissement) Autre.
Public property | Patron | Patron de récurrence.
Public property | PontNational | Indique si la réservation est sur le pont National.
Public property | PreTest | Période de Prétest de la réservation de visioconférence.
Public property | ProprietaireCourriel | Courriel du propriétaire.
Public property | ProprietaireIdentifiant | Identifiant du propriétaire.
Public property | SousTypeReservation | Sous type de la réservation.
Public property | Systemes | Liste des systèmes internes.
Public property | SystemesExternes | Liste des systèmes externes.
Public property | Titre | Titre de la réservation.
Public property | Type | Type de la réservation.
Public property | TypeConnexion | Type de connexion de la réservation de visioconférence.
Top
Remarks
Pour plus de détails, voir WIKI.
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation Properties

IReservation Properties

The IReservation type exposes the following members.

Properties
 | Name | Description
Public property | Accessibilite | L'accessibilité de la réservation.
Public property | Accreditation | L'accréditation pour la réservation.
Public property | ActivitePayante | Activité payante.
Public property | CodeFacturation | Code de facturation.
Public property | Commentaire | Commentaire de la réservation.
Public property | Conferencier | Nom du conférencier.
Public property | DateDebut | Date et heure de début de la réservation en UTC.
Public property | DateFin | Date et heure de fin de la réservation en UTC.
Public property | DateModification | Date et heure UTC de modification de la réservation.
Public property | Description | Description de la réservation.
Public property | DescriptionAccreditation | Description de l'accréditation.
Public property | DescriptionActivitePayante | Description de l'activité payante.
Public property | IdentifiantActivite | Activité de la réservation.
Public property | IdentifiantInstallationOrganisateur | Installation (Établissement/Site) Organisateur.
Public property | IdentifiantPontNational | Numéro de la réservation de visioconférence sur le Pont National.
Public property | IdentifiantReservationPublic | Numéro unique concernant une réservation IRIS.
Public property | IdentifiantSourceExterne | Identifiant de la source Externe.
Public property | IdentifiantSpecialite | Spécialité de la réservation.
Public property | ModeAffichage | Mode d'affichage de la réservation de visioconférence.
Public property | NombreIntervenant | Le nombre d'intervenants pour la réservation.
Public property | NombrePatient | Le nombre de patients de la réservation pour une réservation Avec Patient.
Public property | NomInstallationOrganisateurAutre | Nom de l'installation (Établissement) Autre.
Public property | Patron | Patron de récurrence.
Public property | PontNational | Indique si la réservation est sur le pont National.
Public property | PreTest | Période de Prétest de la réservation de visioconférence.
Public property | ProprietaireCourriel | Courriel du propriétaire.
Public property | ProprietaireIdentifiant | Identifiant du propriétaire.
Public property | SousTypeReservation | Sous type de la réservation.
Public property | Systemes | Liste des systèmes internes.
Public property | SystemesExternes | Liste des systèmes externes.
Public property | Titre | Titre de la réservation.
Public property | Type | Type de la réservation.
Public property | TypeConnexion | Type de connexion de la réservation de visioconférence.
Top
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.Accessibilite Property

IReservationAccessibilite Property

L'accessibilité de la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Accessibilite Accessibilite { get; set; }
Property Accessibilite As Accessibilite
    Get
    Set

Return Value

Type: Accessibilite
L'accessibilité de la réservation.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.Accreditation Property

IReservationAccreditation Property

L'accréditation pour la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
bool Accreditation { get; set; }
Property Accreditation As Boolean
    Get
    Set

Return Value

Type: Boolean
L'accréditation pour la réservation.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.ActivitePayante Property

IReservationActivitePayante Property

Activité payante.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
bool ActivitePayante { get; set; }
Property ActivitePayante As Boolean
    Get
    Set

Return Value

Type: Boolean
Vrai s'il s'agit d'une activité payante.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.CodeFacturation Property

IReservationCodeFacturation Property

Code de facturation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string CodeFacturation { get; set; }
Property CodeFacturation As String
    Get
    Set

Return Value

Type: String
Code de facturation.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.Commentaire Property

IReservationCommentaire Property

Commentaire de la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string Commentaire { get; set; }
Property Commentaire As String
    Get
    Set

Return Value

Type: String
Commentaire de la réservation.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.Conferencier Property

IReservationConferencier Property

Nom du conférencier.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string Conferencier { get; set; }
Property Conferencier As String
    Get
    Set

Return Value

Type: String
Nom du conférencier.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.DateDebut Property

IReservationDateDebut Property

Date et heure de début de la réservation en UTC.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
DateTime DateDebut { get; set; }
Property DateDebut As DateTime
    Get
    Set

Return Value

Type: DateTime
Date et heure de début de la réservation en UTC.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.DateFin Property

IReservationDateFin Property

Date et heure de fin de la réservation en UTC.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
DateTime DateFin { get; set; }
Property DateFin As DateTime
    Get
    Set

Return Value

Type: DateTime
Date et heure de fin de la réservation en UTC.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.DateModification Property

IReservationDateModification Property

Date et heure UTC de modification de la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Nullable<DateTime> DateModification { get; set; }
Property DateModification As Nullable(Of DateTime)
    Get
    Set

Return Value

Type: NullableDateTime
Date et heure UTC de modification de la réservation.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.Description Property

IReservationDescription Property

Description de la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string Description { get; set; }
Property Description As String
    Get
    Set

Return Value

Type: String
Description de la réservation.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.DescriptionAccreditation Property

IReservationDescriptionAccreditation Property

Description de l'accréditation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string DescriptionAccreditation { get; set; }
Property DescriptionAccreditation As String
    Get
    Set

Return Value

Type: String
Description de l'accréditation.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.DescriptionActivitePayante Property

IReservationDescriptionActivitePayante Property

Description de l'activité payante.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string DescriptionActivitePayante { get; set; }
Property DescriptionActivitePayante As String
    Get
    Set

Return Value

Type: String
Description de l'activité payante.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.IdentifiantActivite Property

IReservationIdentifiantActivite Property

Activité de la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
int IdentifiantActivite { get; set; }
Property IdentifiantActivite As Integer
    Get
    Set

Return Value

Type: Int32
Activité de la réservation.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.IdentifiantInstallationOrganisateur Property

IReservationIdentifiantInstallationOrganisateur Property

Installation (Établissement/Site) Organisateur.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
int IdentifiantInstallationOrganisateur { get; set; }
Property IdentifiantInstallationOrganisateur As Integer
    Get
    Set

Return Value

Type: Int32
Installation (Établissement/Site) Organisateur.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.IdentifiantPontNational Property

IReservationIdentifiantPontNational Property

Numéro de la réservation de visioconférence sur le Pont National.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Nullable<int> IdentifiantPontNational { get; set; }
Property IdentifiantPontNational As Nullable(Of Integer)
    Get
    Set

Return Value

Type: NullableInt32
Numéro de la réservation de visioconférence sur le Pont National.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.IdentifiantReservationPublic Property

IReservationIdentifiantReservationPublic Property

Numéro unique concernant une réservation IRIS.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
int IdentifiantReservationPublic { get; set; }
Property IdentifiantReservationPublic As Integer
    Get
    Set

Return Value

Type: Int32
Numéro unique concernant une réservation IRIS.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.IdentifiantSourceExterne Property

IReservationIdentifiantSourceExterne Property

Identifiant de la source Externe.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string IdentifiantSourceExterne { get; set; }
Property IdentifiantSourceExterne As String
    Get
    Set

Return Value

Type: String
Identifiant de la source Externe.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.IdentifiantSpecialite Property

IReservationIdentifiantSpecialite Property

Spécialité de la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
int IdentifiantSpecialite { get; set; }
Property IdentifiantSpecialite As Integer
    Get
    Set

Return Value

Type: Int32
Spécialité de la réservation.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.ModeAffichage Property

IReservationModeAffichage Property

Mode d'affichage de la réservation de visioconférence.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
ModeAffichage ModeAffichage { get; set; }
Property ModeAffichage As ModeAffichage
    Get
    Set

Return Value

Type: ModeAffichage
Mode d'affichage de la réservation de visioconférence.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.NombreIntervenant Property

IReservationNombreIntervenant Property

Le nombre d'intervenants pour la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Nullable<short> NombreIntervenant { get; set; }
Property NombreIntervenant As Nullable(Of Short)
    Get
    Set

Return Value

Type: NullableInt16
Le nombre d'intervenants pour la réservation.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.NombrePatient Property

IReservationNombrePatient Property

Le nombre de patients de la réservation pour une réservation Avec Patient.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Nullable<short> NombrePatient { get; set; }
Property NombrePatient As Nullable(Of Short)
    Get
    Set

Return Value

Type: NullableInt16
Le nombre de patients de la réservation pour une réservation Avec Patient.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.NomInstallationOrganisateurAutre Property

IReservationNomInstallationOrganisateurAutre Property

Nom de l'installation (Établissement) Autre.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string NomInstallationOrganisateurAutre { get; set; }
Property NomInstallationOrganisateurAutre As String
    Get
    Set

Return Value

Type: String
Nom de l'installation (Établissement) Autre.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.Patron Property

IReservationPatron Property

Patron de récurrence.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
PatronRecurrence Patron { get; set; }
Property Patron As PatronRecurrence
    Get
    Set

Return Value

Type: PatronRecurrence
Patron de récurrence.
Remarks
Cette valeur est nulle s'il s'agit d'une réservation qui ne fait pas partie d'une série.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.PontNational Property

IReservationPontNational Property

Indique si la réservation est sur le pont National.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
bool PontNational { get; set; }
Property PontNational As Boolean
    Get
    Set

Return Value

Type: Boolean
Pont National.
Remarks
Si le pont national est vrai, la réservation sera en lançement automatique sur le TMS du Pont National et en réservation seulement pour les autres TMS.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.PreTest Property

IReservationPreTest Property

Période de Prétest de la réservation de visioconférence.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
PreTest PreTest { get; set; }
Property PreTest As PreTest
    Get
    Set

Return Value

Type: PreTest
Période de Prétest de la réservation de visioconférence.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.ProprietaireCourriel Property

IReservationProprietaireCourriel Property

Courriel du propriétaire.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string ProprietaireCourriel { get; set; }
Property ProprietaireCourriel As String
    Get
    Set

Return Value

Type: String
Courriel du propriétaire.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.ProprietaireIdentifiant Property

IReservationProprietaireIdentifiant Property

Identifiant du propriétaire.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
long ProprietaireIdentifiant { get; set; }
Property ProprietaireIdentifiant As Long
    Get
    Set

Return Value

Type: Int64
Identifiant du propriétaire.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.SousTypeReservation Property

IReservationSousTypeReservation Property

Sous type de la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
Nullable<SousTypeReservation> SousTypeReservation { get; set; }
Property SousTypeReservation As Nullable(Of SousTypeReservation)
    Get
    Set

Return Value

Type: NullableSousTypeReservation
Sous type de la réservation.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.Systemes Property

IReservationSystemes Property

Liste des systèmes internes.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
List<Systeme> Systemes { get; set; }
Property Systemes As List(Of Systeme)
    Get
    Set

Return Value

Type: ListSysteme
Liste des systèmes internes.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.SystemesExternes Property

IReservationSystemesExternes Property

Liste des systèmes externes.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
List<SystemeExterne> SystemesExternes { get; set; }
Property SystemesExternes As List(Of SystemeExterne)
    Get
    Set

Return Value

Type: ListSystemeExterne
Liste des systèmes externes.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.Titre Property

IReservationTitre Property

Titre de la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string Titre { get; set; }
Property Titre As String
    Get
    Set

Return Value

Type: String
Titre de la réservation.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.Type Property

IReservationType Property

Type de la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
int Type { get; set; }
Property Type As Integer
    Get
    Set

Return Value

Type: Int32
Type de la réservation.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


IReservation.TypeConnexion Property

IReservationTypeConnexion Property

Type de connexion de la réservation de visioconférence.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
TypeConnexion TypeConnexion { get; set; }
Property TypeConnexion As TypeConnexion
    Get
    Set

Return Value

Type: TypeConnexion
Type de connexion de la réservation de visioconférence.
See Also

Reference

IReservation Interface
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation Class

Reservation Class

Cette classe représente une réservation IRIS.
Inheritance Hierarchy
SystemObject
CHUQ.CSCT.IRIS.Service.Modele.ReservationReservation

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public class Reservation : IReservation
Public Class Reservation
    Implements IReservation

The Reservation type exposes the following members.

Constructors
 | Name | Description
Public method | Reservation | Initializes a new instance of the Reservation class
Top
Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Accessibilite | L'accessibilité de la réservation.
Public property | Accreditation | L'accréditation pour la réservation.
Public property | ActivitePayante | Activité payante.
Public property | CodeFacturation | Code de facturation.
Public property | Commentaire | Commentaire de la réservation.
Public property | Conferencier | Nom du conférencier.
Public property | DateDebut | Date et heure de début de la réservation en UTC.
Public property | DateFin | Date et heure de fin de la réservation en UTC.
Public property | DateModification | Date et heure UTC de modification de la réservation.
Public property | Description | Description de la réservation.
Public property | DescriptionAccreditation | Description de l'accréditation.
Public property | DescriptionActivitePayante | Description de l'activité payante.
Public property | IdentifiantActivite | Activité de la réservation.
Public property | IdentifiantInstallationOrganisateur | Installation (Établissement/Site) Organisateur.
Public property | IdentifiantPontNational | Numéro de la réservation de visioconférence sur le Pont National.
Public property | IdentifiantReservationPublic | Numéro unique concernant une réservation IRIS.
Public property | IdentifiantSourceExterne | Identifiant de la source Externe.
Public property | IdentifiantSpecialite | Spécialité de la réservation.
Public property | ModeAffichage | Mode d'affichage de la réservation de visioconférence.
Public property | NombreIntervenant | Le nombre d'intervenants pour la réservation.
Public property | NombrePatient | Le nombre de patients de la réservation pour une réservation Avec Patient.
Public property | NomInstallationOrganisateurAutre | Nom de l'installation (Établissement) Autre.
Public property | Patron | Patron de récurrence.
Public property | PontNational | Indique si la réservation est sur le pont National.
Public property | PreTest | Période de Prétest de la réservation de visioconférence.
Public property | ProprietaireCourriel | Courriel du propriétaire.
Public property | ProprietaireIdentifiant | Identifiant du propriétaire.
Public property | SousTypeReservation | Sous type de la réservation.
Public property | Systemes | Liste des systèmes internes.
Public property | SystemesExternes | Liste des systèmes externes.
Public property | Titre | Titre de la réservation.
Public property | Type | Type de la réservation.
Public property | TypeConnexion | Type de connexion de la réservation de visioconférence.
Top
Remarks
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation Constructor

Reservation Constructor

Initializes a new instance of the Reservation class

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Reservation()
Public Sub New
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation Methods

Reservation Methods

The Reservation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation Properties

Reservation Properties

The Reservation type exposes the following members.

Properties
 | Name | Description
Public property | Accessibilite | L'accessibilité de la réservation.
Public property | Accreditation | L'accréditation pour la réservation.
Public property | ActivitePayante | Activité payante.
Public property | CodeFacturation | Code de facturation.
Public property | Commentaire | Commentaire de la réservation.
Public property | Conferencier | Nom du conférencier.
Public property | DateDebut | Date et heure de début de la réservation en UTC.
Public property | DateFin | Date et heure de fin de la réservation en UTC.
Public property | DateModification | Date et heure UTC de modification de la réservation.
Public property | Description | Description de la réservation.
Public property | DescriptionAccreditation | Description de l'accréditation.
Public property | DescriptionActivitePayante | Description de l'activité payante.
Public property | IdentifiantActivite | Activité de la réservation.
Public property | IdentifiantInstallationOrganisateur | Installation (Établissement/Site) Organisateur.
Public property | IdentifiantPontNational | Numéro de la réservation de visioconférence sur le Pont National.
Public property | IdentifiantReservationPublic | Numéro unique concernant une réservation IRIS.
Public property | IdentifiantSourceExterne | Identifiant de la source Externe.
Public property | IdentifiantSpecialite | Spécialité de la réservation.
Public property | ModeAffichage | Mode d'affichage de la réservation de visioconférence.
Public property | NombreIntervenant | Le nombre d'intervenants pour la réservation.
Public property | NombrePatient | Le nombre de patients de la réservation pour une réservation Avec Patient.
Public property | NomInstallationOrganisateurAutre | Nom de l'installation (Établissement) Autre.
Public property | Patron | Patron de récurrence.
Public property | PontNational | Indique si la réservation est sur le pont National.
Public property | PreTest | Période de Prétest de la réservation de visioconférence.
Public property | ProprietaireCourriel | Courriel du propriétaire.
Public property | ProprietaireIdentifiant | Identifiant du propriétaire.
Public property | SousTypeReservation | Sous type de la réservation.
Public property | Systemes | Liste des systèmes internes.
Public property | SystemesExternes | Liste des systèmes externes.
Public property | Titre | Titre de la réservation.
Public property | Type | Type de la réservation.
Public property | TypeConnexion | Type de connexion de la réservation de visioconférence.
Top
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.Accessibilite Property

ReservationAccessibilite Property

L'accessibilité de la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Accessibilite Accessibilite { get; set; }
Public Property Accessibilite As Accessibilite
    Get
    Set

Return Value

Type: Accessibilite
L'accessibilité de la réservation.

Implements

IReservationAccessibilite
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.Accreditation Property

ReservationAccreditation Property

L'accréditation pour la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public bool Accreditation { get; set; }
Public Property Accreditation As Boolean
    Get
    Set

Return Value

Type: Boolean
L'accréditation pour la réservation.

Implements

IReservationAccreditation
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.ActivitePayante Property

ReservationActivitePayante Property

Activité payante.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public bool ActivitePayante { get; set; }
Public Property ActivitePayante As Boolean
    Get
    Set

Return Value

Type: Boolean
Vrai s'il s'agit d'une activité payante.

Implements

IReservationActivitePayante
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.CodeFacturation Property

ReservationCodeFacturation Property

Code de facturation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string CodeFacturation { get; set; }
Public Property CodeFacturation As String
    Get
    Set

Return Value

Type: String
Code de facturation.

Implements

IReservationCodeFacturation
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.Commentaire Property

ReservationCommentaire Property

Commentaire de la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string Commentaire { get; set; }
Public Property Commentaire As String
    Get
    Set

Return Value

Type: String
Commentaire de la réservation.

Implements

IReservationCommentaire
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.Conferencier Property

ReservationConferencier Property

Nom du conférencier.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string Conferencier { get; set; }
Public Property Conferencier As String
    Get
    Set

Return Value

Type: String
Nom du conférencier.

Implements

IReservationConferencier
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.DateDebut Property

ReservationDateDebut Property

Date et heure de début de la réservation en UTC.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public DateTime DateDebut { get; set; }
Public Property DateDebut As DateTime
    Get
    Set

Return Value

Type: DateTime
Date et heure de début de la réservation en UTC.

Implements

IReservationDateDebut
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.DateFin Property

ReservationDateFin Property

Date et heure de fin de la réservation en UTC.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public DateTime DateFin { get; set; }
Public Property DateFin As DateTime
    Get
    Set

Return Value

Type: DateTime
Date et heure de fin de la réservation en UTC.

Implements

IReservationDateFin
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.DateModification Property

ReservationDateModification Property

Date et heure UTC de modification de la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Nullable<DateTime> DateModification { get; set; }
Public Property DateModification As Nullable(Of DateTime)
    Get
    Set

Return Value

Type: NullableDateTime
Date et heure UTC de modification de la réservation.

Implements

IReservationDateModification
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.Description Property

ReservationDescription Property

Description de la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Return Value

Type: String
Description de la réservation.

Implements

IReservationDescription
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.DescriptionAccreditation Property

ReservationDescriptionAccreditation Property

Description de l'accréditation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string DescriptionAccreditation { get; set; }
Public Property DescriptionAccreditation As String
    Get
    Set

Return Value

Type: String
Description de l'accréditation.

Implements

IReservationDescriptionAccreditation
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.DescriptionActivitePayante Property

ReservationDescriptionActivitePayante Property

Description de l'activité payante.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string DescriptionActivitePayante { get; set; }
Public Property DescriptionActivitePayante As String
    Get
    Set

Return Value

Type: String
Description de l'activité payante.

Implements

IReservationDescriptionActivitePayante
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.IdentifiantActivite Property

ReservationIdentifiantActivite Property

Activité de la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public int IdentifiantActivite { get; set; }
Public Property IdentifiantActivite As Integer
    Get
    Set

Return Value

Type: Int32
Activité de la réservation.

Implements

IReservationIdentifiantActivite
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.IdentifiantInstallationOrganisateur Property

ReservationIdentifiantInstallationOrganisateur Property

Installation (Établissement/Site) Organisateur.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public int IdentifiantInstallationOrganisateur { get; set; }
Public Property IdentifiantInstallationOrganisateur As Integer
    Get
    Set

Return Value

Type: Int32
Installation (Établissement/Site) Organisateur.

Implements

IReservationIdentifiantInstallationOrganisateur
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.IdentifiantPontNational Property

ReservationIdentifiantPontNational Property

Numéro de la réservation de visioconférence sur le Pont National.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Nullable<int> IdentifiantPontNational { get; set; }
Public Property IdentifiantPontNational As Nullable(Of Integer)
    Get
    Set

Return Value

Type: NullableInt32
Numéro de la réservation de visioconférence sur le Pont National.

Implements

IReservationIdentifiantPontNational
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.IdentifiantReservationPublic Property

ReservationIdentifiantReservationPublic Property

Numéro unique concernant une réservation IRIS.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public int IdentifiantReservationPublic { get; set; }
Public Property IdentifiantReservationPublic As Integer
    Get
    Set

Return Value

Type: Int32
Numéro unique concernant une réservation IRIS.

Implements

IReservationIdentifiantReservationPublic
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.IdentifiantSourceExterne Property

ReservationIdentifiantSourceExterne Property

Identifiant de la source Externe.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string IdentifiantSourceExterne { get; set; }
Public Property IdentifiantSourceExterne As String
    Get
    Set

Return Value

Type: String
Identifiant de la source Externe.

Implements

IReservationIdentifiantSourceExterne
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.IdentifiantSpecialite Property

ReservationIdentifiantSpecialite Property

Spécialité de la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public int IdentifiantSpecialite { get; set; }
Public Property IdentifiantSpecialite As Integer
    Get
    Set

Return Value

Type: Int32
Spécialité de la réservation.

Implements

IReservationIdentifiantSpecialite
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.ModeAffichage Property

ReservationModeAffichage Property

Mode d'affichage de la réservation de visioconférence.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public ModeAffichage ModeAffichage { get; set; }
Public Property ModeAffichage As ModeAffichage
    Get
    Set

Return Value

Type: ModeAffichage
Mode d'affichage de la réservation de visioconférence.

Implements

IReservationModeAffichage
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.NombreIntervenant Property

ReservationNombreIntervenant Property

Le nombre d'intervenants pour la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Nullable<short> NombreIntervenant { get; set; }
Public Property NombreIntervenant As Nullable(Of Short)
    Get
    Set

Return Value

Type: NullableInt16
Le nombre d'intervenants pour la réservation.

Implements

IReservationNombreIntervenant
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.NombrePatient Property

ReservationNombrePatient Property

Le nombre de patients de la réservation pour une réservation Avec Patient.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Nullable<short> NombrePatient { get; set; }
Public Property NombrePatient As Nullable(Of Short)
    Get
    Set

Return Value

Type: NullableInt16
Le nombre de patients de la réservation pour une réservation Avec Patient.

Implements

IReservationNombrePatient
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.NomInstallationOrganisateurAutre Property

ReservationNomInstallationOrganisateurAutre Property

Nom de l'installation (Établissement) Autre.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string NomInstallationOrganisateurAutre { get; set; }
Public Property NomInstallationOrganisateurAutre As String
    Get
    Set

Return Value

Type: String
Nom de l'installation (Établissement) Autre.

Implements

IReservationNomInstallationOrganisateurAutre
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.Patron Property

ReservationPatron Property

Patron de récurrence.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public PatronRecurrence Patron { get; set; }
Public Property Patron As PatronRecurrence
    Get
    Set

Return Value

Type: PatronRecurrence
Patron de récurrence.

Implements

IReservationPatron
Remarks
Cette valeur est nulle s'il s'agit d'une réservation qui ne fait pas partie d'une série.
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.PontNational Property

ReservationPontNational Property

Indique si la réservation est sur le pont National.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public bool PontNational { get; set; }
Public Property PontNational As Boolean
    Get
    Set

Return Value

Type: Boolean
Pont National.

Implements

IReservationPontNational
Remarks
Si le pont national est vrai, la réservation sera en lançement automatique sur le TMS du Pont National et en réservation seulement pour les autres TMS.
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.PreTest Property

ReservationPreTest Property

Période de Prétest de la réservation de visioconférence.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public PreTest PreTest { get; set; }
Public Property PreTest As PreTest
    Get
    Set

Return Value

Type: PreTest
Période de Prétest de la réservation de visioconférence.

Implements

IReservationPreTest
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.ProprietaireCourriel Property

ReservationProprietaireCourriel Property

Courriel du propriétaire.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string ProprietaireCourriel { get; set; }
Public Property ProprietaireCourriel As String
    Get
    Set

Return Value

Type: String
Courriel du propriétaire.

Implements

IReservationProprietaireCourriel
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.ProprietaireIdentifiant Property

ReservationProprietaireIdentifiant Property

Identifiant du propriétaire.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public long ProprietaireIdentifiant { get; set; }
Public Property ProprietaireIdentifiant As Long
    Get
    Set

Return Value

Type: Int64
Identifiant du propriétaire.

Implements

IReservationProprietaireIdentifiant
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.SousTypeReservation Property

ReservationSousTypeReservation Property

Sous type de la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Nullable<SousTypeReservation> SousTypeReservation { get; set; }
Public Property SousTypeReservation As Nullable(Of SousTypeReservation)
    Get
    Set

Return Value

Type: NullableSousTypeReservation
Sous type de la réservation.

Implements

IReservationSousTypeReservation
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.Systemes Property

ReservationSystemes Property

Liste des systèmes internes.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public List<Systeme> Systemes { get; set; }
Public Property Systemes As List(Of Systeme)
    Get
    Set

Return Value

Type: ListSysteme
Liste des systèmes internes.

Implements

IReservationSystemes
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.SystemesExternes Property

ReservationSystemesExternes Property

Liste des systèmes externes.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public List<SystemeExterne> SystemesExternes { get; set; }
Public Property SystemesExternes As List(Of SystemeExterne)
    Get
    Set

Return Value

Type: ListSystemeExterne
Liste des systèmes externes.

Implements

IReservationSystemesExternes
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.Titre Property

ReservationTitre Property

Titre de la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string Titre { get; set; }
Public Property Titre As String
    Get
    Set

Return Value

Type: String
Titre de la réservation.

Implements

IReservationTitre
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.Type Property

ReservationType Property

Type de la réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public int Type { get; set; }
Public Property Type As Integer
    Get
    Set

Return Value

Type: Int32
Type de la réservation.

Implements

IReservationType
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


Reservation.TypeConnexion Property

ReservationTypeConnexion Property

Type de connexion de la réservation de visioconférence.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Reservation
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public TypeConnexion TypeConnexion { get; set; }
Public Property TypeConnexion As TypeConnexion
    Get
    Set

Return Value

Type: TypeConnexion
Type de connexion de la réservation de visioconférence.

Implements

IReservationTypeConnexion
See Also

Reference

Reservation Class
CHUQ.CSCT.IRIS.Service.Modele.Reservation Namespace


CHUQ.CSCT.IRIS.Service.Modele.Specialite Namespace

CHUQ.CSCT.IRIS.Service.Modele.Specialite Namespace

Espace de nom pour l'entité spécialité.
Classes
 | Class | Description
Public class | Specialite | Spécialité.
Interfaces
 | Interface | Description
Public interface | ISpecialite | Spécialité.


ISpecialite Interface

ISpecialite Interface

Spécialité.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Specialite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public interface ISpecialite
Public Interface ISpecialite

The ISpecialite type exposes the following members.

Properties
 | Name | Description
Public property | Identifiant | Identifiant de spécialité.
Public property | Nom | Nom de la spécialité.
Top
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Specialite Namespace


ISpecialite Properties

ISpecialite Properties

The ISpecialite type exposes the following members.

Properties
 | Name | Description
Public property | Identifiant | Identifiant de spécialité.
Public property | Nom | Nom de la spécialité.
Top
See Also

Reference

ISpecialite Interface
CHUQ.CSCT.IRIS.Service.Modele.Specialite Namespace


ISpecialite.Identifiant Property

ISpecialiteIdentifiant Property

Identifiant de spécialité.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Specialite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
int Identifiant { get; set; }
Property Identifiant As Integer
    Get
    Set

Return Value

Type: Int32
Identifiant de spécialité.
See Also

Reference

ISpecialite Interface
CHUQ.CSCT.IRIS.Service.Modele.Specialite Namespace


ISpecialite.Nom Property

ISpecialiteNom Property

Nom de la spécialité.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Specialite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string Nom { get; set; }
Property Nom As String
    Get
    Set

Return Value

Type: String
Nom de la spécialité.
See Also

Reference

ISpecialite Interface
CHUQ.CSCT.IRIS.Service.Modele.Specialite Namespace


Specialite Class

Specialite Class

Spécialité.
Inheritance Hierarchy
SystemObject
CHUQ.CSCT.IRIS.Service.Modele.SpecialiteSpecialite

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Specialite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public class Specialite : ISpecialite
Public Class Specialite
    Implements ISpecialite

The Specialite type exposes the following members.

Constructors
 | Name | Description
Public method | Specialite | Initializes a new instance of the Specialite class
Top
Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Identifiant | Identifiant de spécialité.
Public property | Nom | Nom de la spécialité.
Top
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Specialite Namespace


Specialite Constructor

Specialite Constructor

Initializes a new instance of the Specialite class

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Specialite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Specialite()
Public Sub New
See Also

Reference

Specialite Class
CHUQ.CSCT.IRIS.Service.Modele.Specialite Namespace


Specialite Methods

Specialite Methods

The Specialite type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
See Also

Reference

Specialite Class
CHUQ.CSCT.IRIS.Service.Modele.Specialite Namespace


Specialite Properties

Specialite Properties

The Specialite type exposes the following members.

Properties
 | Name | Description
Public property | Identifiant | Identifiant de spécialité.
Public property | Nom | Nom de la spécialité.
Top
See Also

Reference

Specialite Class
CHUQ.CSCT.IRIS.Service.Modele.Specialite Namespace


Specialite.Identifiant Property

SpecialiteIdentifiant Property

Identifiant de spécialité.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Specialite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public int Identifiant { get; set; }
Public Property Identifiant As Integer
    Get
    Set

Return Value

Type: Int32
Identifiant de spécialité.

Implements

ISpecialiteIdentifiant
See Also

Reference

Specialite Class
CHUQ.CSCT.IRIS.Service.Modele.Specialite Namespace


Specialite.Nom Property

SpecialiteNom Property

Nom de la spécialité.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Specialite
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string Nom { get; set; }
Public Property Nom As String
    Get
    Set

Return Value

Type: String
Nom de la spécialité.

Implements

ISpecialiteNom
See Also

Reference

Specialite Class
CHUQ.CSCT.IRIS.Service.Modele.Specialite Namespace


CHUQ.CSCT.IRIS.Service.Modele.Systeme Namespace

CHUQ.CSCT.IRIS.Service.Modele.Systeme Namespace

Espace de nom pour l'entité système.
Classes
 | Class | Description
Public class | Systeme | Système interne à IRIS.
Interfaces
 | Interface | Description
Public interface | ISysteme | Système interne à IRIS.


ISysteme Interface

ISysteme Interface

Système interne à IRIS.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Systeme
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public interface ISysteme
Public Interface ISysteme

The ISysteme type exposes the following members.

Properties
 | Name | Description
Public property | Identifiant | Numéro de série du système.
Public property | Nom | Nom du système interne.
Top
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Systeme Namespace


ISysteme Properties

ISysteme Properties

The ISysteme type exposes the following members.

Properties
 | Name | Description
Public property | Identifiant | Numéro de série du système.
Public property | Nom | Nom du système interne.
Top
See Also

Reference

ISysteme Interface
CHUQ.CSCT.IRIS.Service.Modele.Systeme Namespace


ISysteme.Identifiant Property

ISystemeIdentifiant Property

Numéro de série du système.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Systeme
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string Identifiant { get; set; }
Property Identifiant As String
    Get
    Set

Return Value

Type: String
Numéro de série du système.
See Also

Reference

ISysteme Interface
CHUQ.CSCT.IRIS.Service.Modele.Systeme Namespace


ISysteme.Nom Property

ISystemeNom Property

Nom du système interne.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Systeme
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string Nom { get; set; }
Property Nom As String
    Get
    Set

Return Value

Type: String
Nom du système interne.
See Also

Reference

ISysteme Interface
CHUQ.CSCT.IRIS.Service.Modele.Systeme Namespace


Systeme Class

Systeme Class

Système interne à IRIS.
Inheritance Hierarchy
SystemObject
CHUQ.CSCT.IRIS.Service.Modele.SystemeSysteme

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Systeme
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public class Systeme : ISysteme
Public Class Systeme
    Implements ISysteme

The Systeme type exposes the following members.

Constructors
 | Name | Description
Public method | Systeme | Initializes a new instance of the Systeme class
Top
Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Identifiant | Numéro de série du système.
Public property | Nom | Nom du système interne.
Top
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Systeme Namespace


Systeme Constructor

Systeme Constructor

Initializes a new instance of the Systeme class

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Systeme
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Systeme()
Public Sub New
See Also

Reference

Systeme Class
CHUQ.CSCT.IRIS.Service.Modele.Systeme Namespace


Systeme Methods

Systeme Methods

The Systeme type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
See Also

Reference

Systeme Class
CHUQ.CSCT.IRIS.Service.Modele.Systeme Namespace


Systeme Properties

Systeme Properties

The Systeme type exposes the following members.

Properties
 | Name | Description
Public property | Identifiant | Numéro de série du système.
Public property | Nom | Nom du système interne.
Top
See Also

Reference

Systeme Class
CHUQ.CSCT.IRIS.Service.Modele.Systeme Namespace


Systeme.Identifiant Property

SystemeIdentifiant Property

Numéro de série du système.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Systeme
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string Identifiant { get; set; }
Public Property Identifiant As String
    Get
    Set

Return Value

Type: String
Numéro de série du système.

Implements

ISystemeIdentifiant
See Also

Reference

Systeme Class
CHUQ.CSCT.IRIS.Service.Modele.Systeme Namespace


Systeme.Nom Property

SystemeNom Property

Nom du système interne.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Systeme
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string Nom { get; set; }
Public Property Nom As String
    Get
    Set

Return Value

Type: String
Nom du système interne.

Implements

ISystemeNom
See Also

Reference

Systeme Class
CHUQ.CSCT.IRIS.Service.Modele.Systeme Namespace


CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace

CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace

Espace de nom pour l'entité système externe.
Classes
 | Class | Description
Public class | SystemeExterne | Système externe d'une réservation IRIS.
Interfaces
 | Interface | Description
Public interface | ISystemeExterne | Système externe d'une réservation IRIS.


ISystemeExterne Interface

ISystemeExterne Interface

Système externe d'une réservation IRIS.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public interface ISystemeExterne
Public Interface ISystemeExterne

The ISystemeExterne type exposes the following members.

Properties
 | Name | Description
Public property | AutreInstallation | Nom de l'installation s'il ne s'agit pas d'une installation faisant partie d'IRIS.
Public property | Direction | Direction.
Public property | Installation | Installation (établissement) dans lequel se trouve le système externe.
Public property | Nom | Nom du système externe.
Public property | Nombre | Nombre/IP.
Public property | Protocole | Protocole du système externe.
Public property | Salle | Nom de la salle dans laquelle se trouve le système externe.
Public property | Type | Type de système externe.
Top
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


ISystemeExterne Properties

ISystemeExterne Properties

The ISystemeExterne type exposes the following members.

Properties
 | Name | Description
Public property | AutreInstallation | Nom de l'installation s'il ne s'agit pas d'une installation faisant partie d'IRIS.
Public property | Direction | Direction.
Public property | Installation | Installation (établissement) dans lequel se trouve le système externe.
Public property | Nom | Nom du système externe.
Public property | Nombre | Nombre/IP.
Public property | Protocole | Protocole du système externe.
Public property | Salle | Nom de la salle dans laquelle se trouve le système externe.
Public property | Type | Type de système externe.
Top
See Also

Reference

ISystemeExterne Interface
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


ISystemeExterne.AutreInstallation Property

ISystemeExterneAutreInstallation Property

Nom de l'installation s'il ne s'agit pas d'une installation faisant partie d'IRIS.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string AutreInstallation { get; set; }
Property AutreInstallation As String
    Get
    Set

Return Value

Type: String
Nom de l'installation s'il ne s'agit pas d'une installation faisant partie d'IRIS.
See Also

Reference

ISystemeExterne Interface
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


ISystemeExterne.Direction Property

ISystemeExterneDirection Property

Direction.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
DirectionEnum Direction { get; set; }
Property Direction As DirectionEnum
    Get
    Set

Return Value

Type: DirectionEnum
Direction.
See Also

Reference

ISystemeExterne Interface
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


ISystemeExterne.Installation Property

ISystemeExterneInstallation Property

Installation (établissement) dans lequel se trouve le système externe.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
int Installation { get; set; }
Property Installation As Integer
    Get
    Set

Return Value

Type: Int32
Installation (établissement) dans lequel se trouve le système externe.
See Also

Reference

ISystemeExterne Interface
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


ISystemeExterne.Nom Property

ISystemeExterneNom Property

Nom du système externe.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string Nom { get; set; }
Property Nom As String
    Get
    Set

Return Value

Type: String
Nom du système externe.
See Also

Reference

ISystemeExterne Interface
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


ISystemeExterne.Nombre Property

ISystemeExterneNombre Property

Nombre/IP.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string Nombre { get; set; }
Property Nombre As String
    Get
    Set

Return Value

Type: String
Nombre/IP.
See Also

Reference

ISystemeExterne Interface
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


ISystemeExterne.Protocole Property

ISystemeExterneProtocole Property

Protocole du système externe.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
ProtocoleEnum Protocole { get; set; }
Property Protocole As ProtocoleEnum
    Get
    Set

Return Value

Type: ProtocoleEnum
Protocole du système externe.
See Also

Reference

ISystemeExterne Interface
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


ISystemeExterne.Salle Property

ISystemeExterneSalle Property

Nom de la salle dans laquelle se trouve le système externe.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string Salle { get; set; }
Property Salle As String
    Get
    Set

Return Value

Type: String
Nom de la salle dans laquelle se trouve le système externe.
See Also

Reference

ISystemeExterne Interface
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


ISystemeExterne.Type Property

ISystemeExterneType Property

Type de système externe.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
TypeEnum Type { get; set; }
Property Type As TypeEnum
    Get
    Set

Return Value

Type: TypeEnum
Type de système externe.
See Also

Reference

ISystemeExterne Interface
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


SystemeExterne Class

SystemeExterne Class

Système externe d'une réservation IRIS.
Inheritance Hierarchy
SystemObject
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterneSystemeExterne

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public class SystemeExterne : ISystemeExterne
Public Class SystemeExterne
    Implements ISystemeExterne

The SystemeExterne type exposes the following members.

Constructors
 | Name | Description
Public method | SystemeExterne | Initializes a new instance of the SystemeExterne class
Top
Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AutreInstallation | Nom de l'installation s'il ne s'agit pas d'une installation faisant partie d'IRIS.
Public property | Direction | Direction.
Public property | Installation | Installation (établissement) dans lequel se trouve le système externe.
Public property | Nom | Nom du système externe.
Public property | Nombre | Nombre/IP.
Public property | Protocole | Protocole du système externe.
Public property | Salle | Nom de la salle dans laquelle se trouve le système externe.
Public property | Type | Type de système externe.
Top
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


SystemeExterne Constructor

SystemeExterne Constructor

Initializes a new instance of the SystemeExterne class

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public SystemeExterne()
Public Sub New
See Also

Reference

SystemeExterne Class
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


SystemeExterne Methods

SystemeExterne Methods

The SystemeExterne type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
See Also

Reference

SystemeExterne Class
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


SystemeExterne Properties

SystemeExterne Properties

The SystemeExterne type exposes the following members.

Properties
 | Name | Description
Public property | AutreInstallation | Nom de l'installation s'il ne s'agit pas d'une installation faisant partie d'IRIS.
Public property | Direction | Direction.
Public property | Installation | Installation (établissement) dans lequel se trouve le système externe.
Public property | Nom | Nom du système externe.
Public property | Nombre | Nombre/IP.
Public property | Protocole | Protocole du système externe.
Public property | Salle | Nom de la salle dans laquelle se trouve le système externe.
Public property | Type | Type de système externe.
Top
See Also

Reference

SystemeExterne Class
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


SystemeExterne.AutreInstallation Property

SystemeExterneAutreInstallation Property

Nom de l'installation s'il ne s'agit pas d'une installation faisant partie d'IRIS.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string AutreInstallation { get; set; }
Public Property AutreInstallation As String
    Get
    Set

Return Value

Type: String
Nom de l'installation s'il ne s'agit pas d'une installation faisant partie d'IRIS.

Implements

ISystemeExterneAutreInstallation
See Also

Reference

SystemeExterne Class
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


SystemeExterne.Direction Property

SystemeExterneDirection Property

Direction.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public DirectionEnum Direction { get; set; }
Public Property Direction As DirectionEnum
    Get
    Set

Return Value

Type: DirectionEnum
Direction.

Implements

ISystemeExterneDirection
See Also

Reference

SystemeExterne Class
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


SystemeExterne.Installation Property

SystemeExterneInstallation Property

Installation (établissement) dans lequel se trouve le système externe.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public int Installation { get; set; }
Public Property Installation As Integer
    Get
    Set

Return Value

Type: Int32
Installation (établissement) dans lequel se trouve le système externe.

Implements

ISystemeExterneInstallation
See Also

Reference

SystemeExterne Class
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


SystemeExterne.Nom Property

SystemeExterneNom Property

Nom du système externe.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string Nom { get; set; }
Public Property Nom As String
    Get
    Set

Return Value

Type: String
Nom du système externe.

Implements

ISystemeExterneNom
See Also

Reference

SystemeExterne Class
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


SystemeExterne.Nombre Property

SystemeExterneNombre Property

Nombre/IP.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string Nombre { get; set; }
Public Property Nombre As String
    Get
    Set

Return Value

Type: String
Nombre/IP.

Implements

ISystemeExterneNombre
See Also

Reference

SystemeExterne Class
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


SystemeExterne.Protocole Property

SystemeExterneProtocole Property

Protocole du système externe.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public ProtocoleEnum Protocole { get; set; }
Public Property Protocole As ProtocoleEnum
    Get
    Set

Return Value

Type: ProtocoleEnum
Protocole du système externe.

Implements

ISystemeExterneProtocole
See Also

Reference

SystemeExterne Class
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


SystemeExterne.Salle Property

SystemeExterneSalle Property

Nom de la salle dans laquelle se trouve le système externe.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string Salle { get; set; }
Public Property Salle As String
    Get
    Set

Return Value

Type: String
Nom de la salle dans laquelle se trouve le système externe.

Implements

ISystemeExterneSalle
See Also

Reference

SystemeExterne Class
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


SystemeExterne.Type Property

SystemeExterneType Property

Type de système externe.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public TypeEnum Type { get; set; }
Public Property Type As TypeEnum
    Get
    Set

Return Value

Type: TypeEnum
Type de système externe.

Implements

ISystemeExterneType
See Also

Reference

SystemeExterne Class
CHUQ.CSCT.IRIS.Service.Modele.SystemeExterne Namespace


CHUQ.CSCT.IRIS.Service.Modele.Type Namespace

CHUQ.CSCT.IRIS.Service.Modele.Type Namespace

Espace de nom pour l'entité type.
Classes
 | Class | Description
Public class | Type | Type de réservation.
Interfaces
 | Interface | Description
Public interface | IType | Type de réservation.


IType Interface

IType Interface

Type de réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Type
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public interface IType
Public Interface IType

The IType type exposes the following members.

Properties
 | Name | Description
Public property | Identifiant | Identifiant de type de réservation.
Public property | Nom | Nom du type de réservation.
Top
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Type Namespace


IType Properties

IType Properties

The IType type exposes the following members.

Properties
 | Name | Description
Public property | Identifiant | Identifiant de type de réservation.
Public property | Nom | Nom du type de réservation.
Top
See Also

Reference

IType Interface
CHUQ.CSCT.IRIS.Service.Modele.Type Namespace


IType.Identifiant Property

ITypeIdentifiant Property

Identifiant de type de réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Type
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
int Identifiant { get; set; }
Property Identifiant As Integer
    Get
    Set

Return Value

Type: Int32
Identifiant de type de réservation.
See Also

Reference

IType Interface
CHUQ.CSCT.IRIS.Service.Modele.Type Namespace


IType.Nom Property

ITypeNom Property

Nom du type de réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Type
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string Nom { get; set; }
Property Nom As String
    Get
    Set

Return Value

Type: String
Nom du type de réservation.
See Also

Reference

IType Interface
CHUQ.CSCT.IRIS.Service.Modele.Type Namespace


Type Class

Type Class

Type de réservation.
Inheritance Hierarchy
SystemObject
CHUQ.CSCT.IRIS.Service.Modele.TypeType

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Type
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public class Type : IType
Public Class Type
    Implements IType

The Type type exposes the following members.

Constructors
 | Name | Description
Public method | Type | Initializes a new instance of the Type class
Top
Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Identifiant | Identifiant de type de réservation.
Public property | Nom | Nom du type de réservation.
Top
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Type Namespace


Type Constructor

Type Constructor

Initializes a new instance of the Type class

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Type
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Type()
Public Sub New
See Also

Reference

Type Class
CHUQ.CSCT.IRIS.Service.Modele.Type Namespace


Type Methods

Type Methods

The Type type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
See Also

Reference

Type Class
CHUQ.CSCT.IRIS.Service.Modele.Type Namespace


Type Properties

Type Properties

The Type type exposes the following members.

Properties
 | Name | Description
Public property | Identifiant | Identifiant de type de réservation.
Public property | Nom | Nom du type de réservation.
Top
See Also

Reference

Type Class
CHUQ.CSCT.IRIS.Service.Modele.Type Namespace


Type.Identifiant Property

TypeIdentifiant Property

Identifiant de type de réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Type
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public int Identifiant { get; set; }
Public Property Identifiant As Integer
    Get
    Set

Return Value

Type: Int32
Identifiant de type de réservation.

Implements

ITypeIdentifiant
See Also

Reference

Type Class
CHUQ.CSCT.IRIS.Service.Modele.Type Namespace


Type.Nom Property

TypeNom Property

Nom du type de réservation.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Type
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string Nom { get; set; }
Public Property Nom As String
    Get
    Set

Return Value

Type: String
Nom du type de réservation.

Implements

ITypeNom
See Also

Reference

Type Class
CHUQ.CSCT.IRIS.Service.Modele.Type Namespace


CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace

CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace

Espace de nom pour les entités utilisateur.
Classes
 | Class | Description
Public class | Utilisateur | Utilisateur avec ses informations de base.
Public class | UtilisateurBase | Objet permetant d'identifier de façon unique un utilisateur IRIS.
Interfaces
 | Interface | Description
Public interface | IUtilisateur | Interface permettant de définir un utilisateur IRIS.
Public interface | IUtilisateurBase | Interface permetant d'identifier de façon unique un utilisateur IRIS.


IUtilisateur Interface

IUtilisateur Interface

Interface permettant de définir un utilisateur IRIS.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Utilisateur
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public interface IUtilisateur : IUtilisateurBase
Public Interface IUtilisateur
    Inherits IUtilisateurBase

The IUtilisateur type exposes the following members.

Properties
 | Name | Description
Public property | Courriel | Courriel de l'utilisateur.
Public property | Domaine | Domaine Active Directory. (Inherited from IUtilisateurBase.)
Public property | IdentifiantUtilisateur | Code utilisateur. (Inherited from IUtilisateurBase.)
Public property | Nom | Nom de famille de l'utilisateur.
Public property | Prenom | Prénom de l'utilisateur.
Top
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


IUtilisateur Properties

IUtilisateur Properties

The IUtilisateur type exposes the following members.

Properties
 | Name | Description
Public property | Courriel | Courriel de l'utilisateur.
Public property | Domaine | Domaine Active Directory. (Inherited from IUtilisateurBase.)
Public property | IdentifiantUtilisateur | Code utilisateur. (Inherited from IUtilisateurBase.)
Public property | Nom | Nom de famille de l'utilisateur.
Public property | Prenom | Prénom de l'utilisateur.
Top
See Also

Reference

IUtilisateur Interface
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


IUtilisateur.Courriel Property

IUtilisateurCourriel Property

Courriel de l'utilisateur.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Utilisateur
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string Courriel { get; set; }
Property Courriel As String
    Get
    Set

Return Value

Type: String
Courriel de l'utilisateur.
See Also

Reference

IUtilisateur Interface
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


IUtilisateur.Nom Property

IUtilisateurNom Property

Nom de famille de l'utilisateur.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Utilisateur
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string Nom { get; set; }
Property Nom As String
    Get
    Set

Return Value

Type: String
Le nom de famille.
See Also

Reference

IUtilisateur Interface
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


IUtilisateur.Prenom Property

IUtilisateurPrenom Property

Prénom de l'utilisateur.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Utilisateur
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string Prenom { get; set; }
Property Prenom As String
    Get
    Set

Return Value

Type: String
Prénom de l'utilisateur.
See Also

Reference

IUtilisateur Interface
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


IUtilisateurBase Interface

IUtilisateurBase Interface

Interface permetant d'identifier de façon unique un utilisateur IRIS.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Utilisateur
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public interface IUtilisateurBase
Public Interface IUtilisateurBase

The IUtilisateurBase type exposes the following members.

Properties
 | Name | Description
Public property | Domaine | Domaine Active Directory.
Public property | IdentifiantUtilisateur | Code utilisateur.
Top
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


IUtilisateurBase Properties

IUtilisateurBase Properties

The IUtilisateurBase type exposes the following members.

Properties
 | Name | Description
Public property | Domaine | Domaine Active Directory.
Public property | IdentifiantUtilisateur | Code utilisateur.
Top
See Also

Reference

IUtilisateurBase Interface
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


IUtilisateurBase.Domaine Property

IUtilisateurBaseDomaine Property

Domaine Active Directory.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Utilisateur
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
DomaineActiveDirectory Domaine { get; set; }
Property Domaine As DomaineActiveDirectory
    Get
    Set

Return Value

Type: DomaineActiveDirectory
Le domaine Active Directory.
See Also

Reference

IUtilisateurBase Interface
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


IUtilisateurBase.IdentifiantUtilisateur Property

IUtilisateurBaseIdentifiantUtilisateur Property

Code utilisateur.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Utilisateur
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
string IdentifiantUtilisateur { get; set; }
Property IdentifiantUtilisateur As String
    Get
    Set

Return Value

Type: String
Code de l'utilisateur.
See Also

Reference

IUtilisateurBase Interface
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


Utilisateur Class

Utilisateur Class

Utilisateur avec ses informations de base.
Inheritance Hierarchy
SystemObject
CHUQ.CSCT.IRIS.Service.Modele.UtilisateurUtilisateur

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Utilisateur
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public class Utilisateur : IUtilisateur
Public Class Utilisateur
    Implements IUtilisateur

The Utilisateur type exposes the following members.

Constructors
 | Name | Description
Public method | Utilisateur | Initializes a new instance of the Utilisateur class
Top
Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Courriel | L'adresse courriel de l'utilisateur.
Public property | Domaine | Domaine Active Directorty dans lequel se trouve l'utilisateur.
Public property | IdentifiantUtilisateur | Code de l'utilisateur.
Public property | Nom | Le nom de famille de l'utilisateur.
Public property | Prenom | Le prénom de l'utilisateur.
Top
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


Utilisateur Constructor

Utilisateur Constructor

Initializes a new instance of the Utilisateur class

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Utilisateur
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public Utilisateur()
Public Sub New
See Also

Reference

Utilisateur Class
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


Utilisateur Methods

Utilisateur Methods

The Utilisateur type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
See Also

Reference

Utilisateur Class
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


Utilisateur Properties

Utilisateur Properties

The Utilisateur type exposes the following members.

Properties
 | Name | Description
Public property | Courriel | L'adresse courriel de l'utilisateur.
Public property | Domaine | Domaine Active Directorty dans lequel se trouve l'utilisateur.
Public property | IdentifiantUtilisateur | Code de l'utilisateur.
Public property | Nom | Le nom de famille de l'utilisateur.
Public property | Prenom | Le prénom de l'utilisateur.
Top
See Also

Reference

Utilisateur Class
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


Utilisateur.Courriel Property

UtilisateurCourriel Property

L'adresse courriel de l'utilisateur.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Utilisateur
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string Courriel { get; set; }
Public Property Courriel As String
    Get
    Set

Return Value

Type: String
L'adresse courriel de l'utilisateur.

Implements

IUtilisateurCourriel
See Also

Reference

Utilisateur Class
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


Utilisateur.Domaine Property

UtilisateurDomaine Property

Domaine Active Directorty dans lequel se trouve l'utilisateur.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Utilisateur
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public DomaineActiveDirectory Domaine { get; set; }
Public Property Domaine As DomaineActiveDirectory
    Get
    Set

Return Value

Type: DomaineActiveDirectory
Le domaine Active Directory de l'utilisateur.

Implements

IUtilisateurBaseDomaine
See Also

Reference

Utilisateur Class
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


Utilisateur.IdentifiantUtilisateur Property

UtilisateurIdentifiantUtilisateur Property

Code de l'utilisateur.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Utilisateur
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string IdentifiantUtilisateur { get; set; }
Public Property IdentifiantUtilisateur As String
    Get
    Set

Return Value

Type: String
Le code de l'utilisateur.

Implements

IUtilisateurBaseIdentifiantUtilisateur
See Also

Reference

Utilisateur Class
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


Utilisateur.Nom Property

UtilisateurNom Property

Le nom de famille de l'utilisateur.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Utilisateur
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string Nom { get; set; }
Public Property Nom As String
    Get
    Set

Return Value

Type: String
Le nom de famille de l'utilisateur.

Implements

IUtilisateurNom
See Also

Reference

Utilisateur Class
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


Utilisateur.Prenom Property

UtilisateurPrenom Property

Le prénom de l'utilisateur.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Utilisateur
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string Prenom { get; set; }
Public Property Prenom As String
    Get
    Set

Return Value

Type: String
Le prénom de l'utilisateur.

Implements

IUtilisateurPrenom
See Also

Reference

Utilisateur Class
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


UtilisateurBase Class

UtilisateurBase Class

Objet permetant d'identifier de façon unique un utilisateur IRIS.
Inheritance Hierarchy
SystemObject
CHUQ.CSCT.IRIS.Service.Modele.UtilisateurUtilisateurBase

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Utilisateur
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public class UtilisateurBase : IUtilisateurBase
Public Class UtilisateurBase
    Implements IUtilisateurBase

The UtilisateurBase type exposes the following members.

Constructors
 | Name | Description
Public method | UtilisateurBase | Initializes a new instance of the UtilisateurBase class
Top
Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Domaine | Domaine Active Directory de l'utilisateur.
Public property | IdentifiantUtilisateur | Code utilisateur.
Top
See Also

Reference

CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


UtilisateurBase Constructor

UtilisateurBase Constructor

Initializes a new instance of the UtilisateurBase class

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Utilisateur
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public UtilisateurBase()
Public Sub New
See Also

Reference

UtilisateurBase Class
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


UtilisateurBase Methods

UtilisateurBase Methods

The UtilisateurBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Détermine si l'objet spécifié est identique à l'objet actuel. (Inherited from Object.)
Public method | GetHashCode | Sert de fonction de hachage par défaut. (Inherited from Object.)
Public method | GetType | Obtient le Type de l'instance actuelle. (Inherited from Object.)
Public method | ToString | Retourne une chaîne qui représente l'objet actif. (Inherited from Object.)
Top
See Also

Reference

UtilisateurBase Class
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


UtilisateurBase Properties

UtilisateurBase Properties

The UtilisateurBase type exposes the following members.

Properties
 | Name | Description
Public property | Domaine | Domaine Active Directory de l'utilisateur.
Public property | IdentifiantUtilisateur | Code utilisateur.
Top
See Also

Reference

UtilisateurBase Class
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


UtilisateurBase.Domaine Property

UtilisateurBaseDomaine Property

Domaine Active Directory de l'utilisateur.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Utilisateur
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public DomaineActiveDirectory Domaine { get; set; }
Public Property Domaine As DomaineActiveDirectory
    Get
    Set

Return Value

Type: DomaineActiveDirectory
Domaine Active Directory de l'utilisateur.

Implements

IUtilisateurBaseDomaine
See Also

Reference

UtilisateurBase Class
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace


UtilisateurBase.IdentifiantUtilisateur Property

UtilisateurBaseIdentifiantUtilisateur Property

Code utilisateur.

Namespace: CHUQ.CSCT.IRIS.Service.Modele.Utilisateur
Assembly: CHUQ.CSCT.IRIS.Service (in CHUQ.CSCT.IRIS.Service.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
Copy
public string IdentifiantUtilisateur { get; set; }
Public Property IdentifiantUtilisateur As String
    Get
    Set

Return Value

Type: String
Code utilisateur.

Implements

IUtilisateurBaseIdentifiantUtilisateur
See Also

Reference

UtilisateurBase Class
CHUQ.CSCT.IRIS.Service.Modele.Utilisateur Namespace